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Select and utilize tools to design and develop web5|tes
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Hypertext Markup Language

(HTML)

d Basic framework for all web design.

d Written using “tags” that a web
browser uses to interpret the code
and generate the content on the

webpage.
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 Tags denote structured elements -
like headings, paragraphs, lists, etc. = a=2
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HTML Explained

(1 Most tags must have two parts, an opening and a
closing part.

O <html> is the opening tag
O </html>is the closing tag

d Attributes are defined within the opening tag.
O <img src="imagel.jpg'">
O <p align="center"> ... </p>
(1 Use this Simple Guide to HTML page to learn more.
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Required HTML Tags

d Below is a basic html document that contains the 4
required tags. Notice the nesting of the html tags.

<html>

<head>

<title>this is the title</title>

</head>

<body> this is everything that goes in the document! </
body>

</html>
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Basic HTML Tags

1 Headings
O <h1> A Heading </h1>

J Paragraphs
O <p>Some text </p>
d Links
O <a href="home.html!"> My homepage </a>
J Images
0 <img src="photo.jpg">
(d HTML Cheat Sheet
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Cascading Style Sheets (CSS)

1 Separates layout and design
features (color scheme, fonts,
menu styles, etc.) from the
actual content of the website.

(] Easiest way to make site-wide
design changes.

J CSS file combines with HTML
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CSS Explained

J A CSS rule-set consists of a selector and a
declaration block.

O The selector points to the element you want to
style.

0 The declaration block contains one or more
declarations separated by semicolons.

0 Each declaration includes a CSS property name
and a value, separated by a colon.
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CSS Explained

O A CSS declaration always ends with a semicolon,
and declaration blocks are surrounded by curly

braces.
Selector Declaration Declaration
@ { color:blue; font-size:12px; }

Property Value Property Value

(J Use this Learn CSS to learn more.
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Advanced Style Sheet Terms

1 Class Style

O Used to specify a style for a
group of components in a
website; allows you to set
up a particular style for
many HTML elements
tagged with the same class.

1 ID Style

O Used to specify a style for a
single, unique element in a
website.

hi { color: white;
background: orange;
border: 1px solid bla
padding: 0 0 0 0;
font-weight: bold;

/* begin: seaside-theme */

body {
background-color:white;
color:black;

font-family:Arial, sans-serif;

margin: 0 4px 0 0;
border: 12px solid;
}
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Advanced Style Sheet Terms

1 Internal Style Sheet

O A CSS document contains the design properties
of the website.

0 Embedded into the HTML file so can be moved
with the website files.

(J External Style Sheet

O A CSS document contains the design properties
of the website.

O Housed separately from the HTML file and
therefore can be attached to many different
websites.
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Common Web Design Languages

1 JavaScript
O Client-side web development.

0 Creates standalone computer
actions that run entirely on
the user’s machine.

0 Quicker and more secure.
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Panels in Design View

(1 Design Panel
O Code View
O Split View

] Files Panel

 Insert Panel

1 Property Inspector
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Design Panel

1 Design view is a WYSIWYG interface.

1 Add content and the code is written automatically.
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Code vs. Split View

] Code view can see and write code.

 Split view can see design and code views. Can edit
in either area. .
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Files Panel

(d Enables you to view files and folders, whether they
are associated with a Dreamweaver site or not.

1 Perform standard file maintenance operations, such
as opening and moving files.
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Insert Panel

1 Contains buttons for creating and inserting objects
such as tables and images.

1 The buttons are organized into categories.

[® Paragraph

* Heading : H3
Table
@ Figure

ul Unordered List

ol Ordered List v
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Properties Inspector

d Lets you examine and edit the most common
properties for the currently selected page element,
such as text or an inserted object.

J The contents of the Property inspector vary
depending on the element(s) selected.

Properties
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Customize Workspace

 Your Dreamweaver workspace can be changed to
best meet your needs as a designer.

0 Change document views

O Rearrange/resize windows and panels
O Add or remove tools on toolbar

O Create and save custom workspace

(d These same techniques can be used to customize
other Adobe software.



ExplorNet's Digital Media I
Web Design Production Terms

D R O Ot F O | d e r Files CC Libraries Insert CSS Designer

B3 Training v ( Define Servers

00 A central location of storage  wu. |
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J First step in creating website, S ey
should be to define the site which
requires the following:

O Name the website
0 Choose local folder (root folder)
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Define Site

 In Dreamweaver, use Site>New Site to access Site
Setup dialog box.

(J Once the root folder is set, the file list in the Files
panel acts as a file manager, allowing you to copy
paste, delete, move, and open files just as you
would on a desktop.

d This organizes all files associated with website
including:
O Track and maintain links
O Manage files

O Transfer files to web server
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Web Page File Name
Conventions

I File and folder names in websites should never
contain spaces or symbols.

1 Most file and folder names end up as part of a web
page's URL, so keep them short, but meaningful.

1 Using all lowercase letters for file and folder names

avoids problems with files not being found. NO
UPPERCASE.

1 Home page should always be named index.html.
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Create New Web Page

d In Dreamweaver, use File>New to open New
Document dialog box.

d Select the following:
[0 New Document

O Title =yowy =
0 Doc Type: HTML5
O Create Iz

J Choose File>Save
0 Check for root folder
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Web Design Production Terms

d Wireframe (Skeleton)

O A visual guide to how web page content will be
organized; assists in the arrangement and scaling
of design components.

O Similar to storyboarding in animation or video.
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Add Text

1 You can type text directly in the Document window,
or you can cut and paste text. You can also import

text from other documents.

(1 Use the text Property Inspector to apply HTML
formatting or Cascading Style Sheet (CSS)

formatting.
J Select the text to be formatted before applying

formatting change.
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Graphics for Web Use

1 Graphics Optimization
0 Design graphics with the specific purpose of
using it on a website.
O Allows for quicker loading times.
0 Adobe PhotoShop has save for Web or optimize
options.
0 Choose appropriate file format for web.
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Insert Graphic

1 In Dreamweaver images may be inserted using a
variety of commands.

d One such way is:

O Place insertion point where you want image.
O Select Insert>Image

O File will be copied to root folder (if not already
there).
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Images Property Inspector

d The Images Property Inspector allows you to set
properties for an image. If you do not see all options
click the expander arrow in corner.

J Use the ALT area to add alternative text.

O Textual descriptions of graphics and other design
components on a web page; aids in screen
reader use for accessibility.
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Web Design Production Terms

d Image Map

O A single graphic that is divided into sections and
linked to different locations. Example

(J Hotspot

O Specify a particular area as a link; can be drawn
over a block of space, words, or an image.
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Hyperlinks

1 Hyperlinks (Links)

O Clickable connections that link text
or images to other pages of the
website, out to external websites, or
to files posted on a website.

1 Email Link (mailto)

0 Does not link to an Internet location;
causes the user’s computer to open
the default email program and
prepares a blank email to the
specified address.
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Add Hyperlinks

1 In the Properties Panel use the Link area to create a
hypertext link of the selected text:

O Click the folder icon to browse to a file in your
Site.

O Type the URL.

0 Drag the Point-To-File icon to a file in the Files
panel

0 Drag a file from the Files panel into the box.
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Add Hyperlink Targets

1 In the Properties Panel use the Target area to

specify the frame or window in which the linked
document will load:

O _self -- opens in the same window and frame.

[0 _top -- opens in the same window, making the
frame full size.

[0 _parent -- opens in the parent page’s frame.
O _blank -- opens in a new window and frame.
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Advanced Hyperlink Terms

] Absolute Link

0 Contain a complete web address; always includes
domain name of website.

O Great explanation here! http://
www.coffeecup.com/help/articles/absolute-vs-
relative-pathslinks/

Absolute Paths Examples
ehttp://www.mysite.com
ehttp://www.mysite.com/graphics/image.png



ExplorNet's Digital Media I
Advanced Hyperlink Terms

] Relative Link

O Starts from the home page or root folder of the
website and creates a path to the destination of
the link.

Relative Paths Examples
eindex.html

e /graphics/image.png
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Insert Rollover

] Rollover

0 Feature that indicates interactivity to the user;
normally causes a component of a web page to
visually change when the user’s cursor hovers

over it. .M w

Normal state Rollover state

(d Can be made in a graphic editing program or found
online.

(1 Need two images for each rollover.
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Insert Rollover

(1 Create a simple rollover effect with two images:

[

N R N N O N O

Insert cursor where you want rollover.
Choose Insert>HTML>Rollover Image.
Give the rollover a name.

Choose the original and rollover images.

Add alternate text.
Image name: | Image4 |
Choose location.
. Rollover image:
Cl I C k O K . Preload rollover image

Alternate text

When clicked, Go to URL:

OK

0
1)
=
0
o

Help
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Insert Navigation Bar

1 Rollover buttons may be used to create navigation
bars.

J Use the web design conventions of placing
navigation bar:
O Horizontally across top of page
O Vertically on left side of page

Vertical Horizontal

Lhome WMlone | news  contac About

News

Contact Home News About

About

J Be sure that buttons are consistent in size and color.
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Create Forms

J Web Form
O An interactive feature that allows a user to
submit information.

J Forms can be created within the web editor
program.

(d Or forms can be created using an external program
such as Google Forms and linked to the page.

1 Using a form editor is often easier and will include a
database to collect the data.



