
	
   	
  

	
  

Dear	
  Candidate,	
  

In	
  preparation	
  for	
  the	
  Interactive	
  Media	
  certification	
  exam,	
  we’ve	
  put	
  together	
  a	
  set	
  of	
  practice	
  
materials	
  and	
  example	
  exam	
  items	
  for	
  you	
  to	
  review.	
  	
  What	
  you’ll	
  find	
  in	
  this	
  packet	
  are:	
  

§ Topic	
  areas	
  and	
  objectives	
  for	
  the	
  exam.	
  	
  

§ Practice	
  materials	
  with	
  image	
  assets.	
  

§ Practice	
  exam	
  items.	
  

We’ve	
  assembled	
  excerpted	
  material	
  from	
  the	
  Interactive	
  Design	
  Curriculum	
  guide	
  to	
  highlight	
  a	
  few	
  of	
  
the	
  more	
  challenging	
  techniques	
  covered	
  on	
  the	
  exam.	
  	
  You	
  can	
  work	
  through	
  these	
  technical	
  guides	
  
with	
  the	
  provided	
  image	
  and	
  video	
  files	
  (provided	
  separately).	
  Additionally,	
  we’ve	
  included	
  the	
  
certification	
  objectives	
  so	
  that	
  you	
  are	
  aware	
  of	
  the	
  elements	
  that	
  are	
  covered	
  on	
  the	
  exam.	
  Finally,	
  
we’ve	
  included	
  practice	
  exam	
  items	
  to	
  give	
  you	
  a	
  feel	
  for	
  some	
  of	
  the	
  items.	
  	
  

These	
  materials	
  are	
  meant	
  to	
  help	
  you	
  familiarize	
  yourself	
  with	
  the	
  areas	
  of	
  the	
  exam	
  so	
  are	
  not	
  
comprehensive	
  across	
  all	
  the	
  objectives.	
  

Thank	
  you,	
  

Adobe	
  Education	
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Adobe Interactive Media using Adobe Flash Professional 
Exam and objectives 

After taking the exam, your score is electronically reported.  Please allow 2-4 weeks from the date you pass 
the exam to receive your ACA Welcome Kit. 

Exam Structure 
 
The following lists the topic areas for the exam:  

• Setting project requirements 

• Identifying interactive media design elements 

• Understanding the Adobe Flash Professional interface 

• Building interactive media elements by using Flash Professional 

• Evaluating interactive media elements by using Flash Professional 

 
Number of Questions and Time 
  

• 40 questions  

• 50 minutes  

 
Exam Objectives 
Domain 1.0 Setting Project Requirements 

1.1 Identify the purpose, audience, and audience needs for interactive media content. 

1.2 Identify interactive media content that is relevant to the purpose of the media in which it will be used (websites, 
mobile devices, and so on). 

1.3 Understand options for producing accessible interactive media content. 

1.4 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing 
copyrighted material).  

1.5 Understand project management tasks and responsibilities. 

1.6. Communicate with others (such as peers and clients) about design and content plans. 

Domain 2.0 Identifying Interactive Media Design Elements 

2.1 Identify best practices for designing interactive media content for desktop and mobile browsers, applications, 
games, and HD video. 

2.2 Demonstrate knowledge of design elements and principles. 

2.3 Identify general techniques to create interactive media elements that are accessible and readable. 

2.4 Use a storyboard to produce interactive media elements. 

2.5 Organize an interactive media document. 

Domain 3.0 Understanding Adobe Flash Interface 

3.1 Identify elements of the Flash interface. 

3.2 Use the Property inspector. 

3.3 Use the Timeline. 



Adobe Interactive Media using Adobe Flash Professional 
 ©2012 Adobe Systems Incorporated 

3.4 Adjust document properties. 

3.5 Use Flash guides and rulers. 

3.6 Use the Motion Editor. 

3.7 Understand Flash file types. 

3.8 Identify best practices for managing the file size of a published Flash or HTML document. 

Domain 4.0 Building Interactive Media Elements by Using Flash Professional 

4.1 Make interactive media content development decisions based on your analysis and interpretation of design 
specifications. 

4.2 Use tools on the Tools panel to select, create, and manipulate graphics and text. 

4.3 Import and modify graphics. 

4.4 Create text.  

4.5 Adjust text properties.  

4.6 Create objects and convert them to symbols, including graphics, movie clips, and buttons. 

4.7 Understand symbols and the library. 

4.8 Edit symbols and instances 

4.9 Create masks. 

4.10 Create animations (changes in shape, position, size, color, and transparency). 

4.11 Add simple controls through ActionScript 3.0. 

4.12 Import and use sound. 

4.13 Add and export video. 

4.14 Publish and export Flash documents. 

4.15 Make a Flash document accessible 

Domain 5.0 Evaluating Interactive Media Elements by Using Flash Professional 

5.1 Conduct basic technical tests. 

5.2 Identify techniques for basic usability tests. 



Adobe Flash Professional Guide
Overview of Adobe Flash Professional
In this guide, you learn how to do the following:

• Identify the elements of the Adobe Flash Professional workspace

• Customize the layout of the workspace

• Define the tools and features in the workspace

Workspace

Figure 1 Flash workspace

Timeline panel

Stage Properties panel

Tools panel

Workspace switcher
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Arranging the Flash workspace

You can create a custom workspace by moving and manipulating panels, such as adding, removing, docking, 
grouping, or collapsing them. You can save these custom workspaces and switch among them. Flash provides several 
preset workspaces, arranged for particular tasks or types of users.

To switch between workspaces:

1. Start Flash and choose File > New (ActionScript 3.0). 

An empty Flash document opens.

2. Select a preset workspace (such as Designer) using the 
workspace switcher at the top of the workspace 
(Figure 2).

The panels are rearranged.

Figure 2 Workspace switcher at the top of the 
workspace

To create a custom workspace:

1. Start Flash and choose File > New (ActionScript 3.0). 

An empty Flash document opens.

2. Make changes to an existing workspace, such as by 
opening new panels or closing open panels.

3. Choose Window > Workspace > New Workspace (or 
choose New Workspace in the workspace switcher).

The New Workspace dialog box opens (Figure 3).

4. Enter a name for the new workspace.

5. Click OK.

The workspace is now available through the workspace 
switcher.

Figure 3 New Workspace dialog box

Stage

The Stage is the white, rectangular area of the Adobe Flash Professional workspace (Figure 1). Objects you place on 
the Stage will appear in your published movie. Objects placed in the pasteboard (the gray area around the Stage) will 
not appear in the finished movie, but you can place objects there until you want them to appear on the Stage.
Overview of the Adobe Flash Professional © 2013 Adobe Systems Incorporated
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Timeline panel

The Timeline panel is where you control the images and sounds in your Flash document (Figure 4). The timeline is 
divided into frames. In the timeline, you work with these frames to organize and control the content of your 
document. You place frames in the timeline in the order you want the objects in the frames to appear in your finished 
content.

A keyframe indicates a change occurring in the timeline, for example a keyframe can indicate the moment at which a 
graphic image appears or changes in the movie. A keyframe can also be a frame that includes ActionScript code to 
control some aspect of your document. You can also add a blank keyframe to the timeline as a placeholder for 
symbols you plan to add later or to explicitly leave the frame blank.

A property keyframe is a frame in which you define a change to an object’s properties for an animation. Flash can 
tween, or automatically fill in, the property values between property keyframes to produce fluid animations. Because 
property keyframes let you produce animation without drawing each individual frame, they make creating animation 
easier. A series of frames containing tweened animation is called a motion tween.

Current frame, frame rate, and elapsed time are all shown at the bottom of the Timeline panel. The playhead, 
represented by a red rectangle with a long red line, shows the current frame you are viewing on the timeline. You can 
click a frame to move the playhead to that frame, or you can drag the playhead back and forth on the timeline to 
quickly view all or any part of your animation.

Layers in the Timeline panel provide a way to organize the elements of your movie. You can draw and edit objects on 
one layer without affecting objects on another layer. Layers control the stacking order of objects—the order moves 
from top to bottom, so objects displayed in front are in the top layer, while objects displayed in back are in the bottom 
layer. This allows you to place objects in front of or behind one another. To change the order of layers, drag the layer 
name to a new position. The layer controls appear on the left side of the Timeline panel. Each layer has an option for 
hiding or showing the layer, locking it, and displaying its contents as outlines.

Figure 4  Timeline panel

Layers
Show/Hide 
Layer

Lock/Unlock
Layer Playhead

Insert 
Layer

Insert Layer
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Delete Layer Current 
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Edit bar

The edit bar, at the top of the Stage, lets you quickly navigate between different parts of your Flash document 
(Figure 5). It lets you switch between scenes and symbols. You can also change the magnification level of the Stage. 

Figure 5 Edit bar

Panels

Panels provide easy access to controls that help you work with the content in your document (Figure 6). By default, 
the Properties panel and the Library panel are docked to the right side of the workspace. Any available panel can be 
opened by selecting it in the Window menu. By default, several panels are collapsed to icons to make them easy to 
open while reducing clutter in the workspace. To open and close these iconic panels (Figure 6) click their icons.

You can undock panel groups, add panels to a group, undock individual panels, rearrange the order of docked panels, 
and collapse and close panel groups. To undock a panel, drag it by its tab or title bar away from its current position. 
You can drag it into another dock or make it free-floating.

Figure 6 Panels

Select Scene Select Symbols Change MagnificationCurrent Scene

Panel menuPanelsIconic panels
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Tools panel

The tools in the Tools panel let you draw, paint, select, and modify artwork, as well as change the view of the Stage 
(Figure 7). The Options area at the bottom of the Tools panel lets you modify a tool you have selected. If the Tools 
panel is not visible, you can display it by selecting Window > Tools. To select a tool, just click it. (You can also use 
the shortcut key shown in parentheses in the tool tip that appears when you rest the pointer over a tool for a few 
seconds.) Properties for the selected tool appear in the Properties panel. Some tools are arranged in groups, with only 
one tool shown for each group and the other tools in the group hidden behind that tool. A small triangle in the lower 
right corner of a tool icon is your clue to look for hidden tools. Select a hidden tool by clicking and holding down the 
small triangle.

Figure 7 Flash Tools panel
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© 2013 Adobe Systems Incorporated Overview of the Adobe Flash Professional 5

This document requires Adobe Flash Professional CC, June 2013. Technical instructions may differ depending on your version.



Guide Adobe Flash Professional

6

Selection tools

Selection tool (black arrow): Click an object to select it. Drag a selected object to move it.

Subselection tool (white arrow): Select and move points of an object or edit paths between adjacent points.

Free Transform tool: Resize or rotate selected objects by dragging. 

Gradient Transform tool: Transform a gradient or bitmap fill by adjusting the size, direction, or center of the fill.

3D Rotation tool: Rotate movie clip instances in 3D space. A 3D rotation control appears on top of selected objects 
on the Stage. The X control is red, the Y control is green, and the Z control is blue. 

3D Translation tool: Move movie clip instances in 3D space. When you select a movie clip with the tool, its axes, X, 
Y, and Z, appear on the Stage on top of the object. The X axis is red, the Y axis is green, and the Z axis is blue.

Lasso tool: Drag to select an area.

Drawing tools

Pen tool: Create straight or curved lines. You can also create Bezier curves. 

Add Anchor Point tool: Add new anchor points to an existing path.

Delete Anchor Point tool: Delete anchor points from a path.

Convert Anchor Point tool: Convert the points on a path between corners to smooth points.

Text tool: Create or edit text and text fields.

Line tool: Draw straight lines.

Rectangle tool: Create rectangles or squares composed of fills and strokes, just fills, or just strokes. Rectangle 
Primitive tool creates shapes that are individual objects that can be edited in the Properties panel.

Oval tool: Create circles and ovals, the Rectangle Primitive tool, and the Oval Primitive tool. 

PolyStar tool: Create either polygon or star shapes—you can set how many points both shapes have.

Pencil tool: Create lines in any of three modes—straighten, smooth, or ink. 

Brush tool: Create shapes with fills only. Also has the 

Paint Bucket tool: Add fill inside a shape or change the fill color.

Ink Bottle tool: Change the color or width of a line, or add a stroke to a shape.

Eyedropper tool: Sample a color from swatches or anywhere on the screen.

Eraser tool: Erase parts of an image.

View tools

Hand tool: Drag the Stage to view another part of your document.

Zoom tool: Zoom in or out to view more or less of the Stage. To zoom out, hold down the Alt key (Windows) or the 
Option key (Mac OS).

Color tools

Stroke Color: Set the stroke color.

Fill Color: Set the fill color.
Overview of the Adobe Flash Professional © 2013 Adobe Systems Incorporated
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Properties panel

The Properties panel provides easy access to the most commonly used attributes of the current selection, either on the 
Stage or in the timeline. You can make changes to the object or document attributes in the Properties panel without 
accessing the menus or other panels that also control these attributes.

Depending on what is currently selected, the Properties panel displays information and settings for the current 
document, text, symbol, shape, bitmap, video, group, frame, or tool. For example, in the Properties panel you can edit 
the document size or select publish settings, including the target Flash Player and ActionScript versions. 

When two or more different types of objects are selected, the Properties panel displays the total number of objects 
selected. By default, the Properties panel is visible; you can hide or show it by selecting Window > Properties. The 
illustrations (Figure 8) show the properties for a Flash document and a text object, respectively.

Figure 8  Properties panel for a Flash document (left) and a text object (right)
© 2013 Adobe Systems Incorporated Overview of the Adobe Flash Professional 7
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Understanding frames and keyframes
Like films, Adobe Flash Professional documents divide lengths of time into frames. In the timeline, you work with 
these frames to organize and control the content of your document. You place frames in the timeline in the order you 
want the objects in the frames to appear in your finished content. 

Frames define increments on the timeline (Figure 1). The order in which frames appear on the timeline determines 
the order in which they appear when a Flash document plays. You can arrange keyframes on the timeline to edit the 
sequence of events in an animation.

A keyframe is a frame where a change occurs in the timeline. For example, a keyframe can indicate where a new 
symbol instance appears in the timeline. A keyframe can also be a frame that includes ActionScript code to control 
some aspect of your document. You can also add a blank keyframe to the timeline as a placeholder for symbols you 
plan to add later or to explicitly leave the frame blank.

A property keyframe is a frame in which you define a change to an object’s properties for an animation. Flash can 
tween, or automatically fill in, the property values between the property keyframes in order to produce fluid 
animations. Because property keyframes let you produce animation without drawing each individual frame, they 
make creating animation easier. A series of frames containing tweened animation is called a motion tween.

A tweened frame is any frame that is part of a tween.

A static frame is any frame that is not part of a tween.

You arrange keyframes and property keyframes in the timeline to control the sequence of events in your document 
and its animation.

A keyframe is indicated on the timeline with a solid black circle. The frame where a keyframe span ends has a small 
white rectangle. A blank keyframe is indicated by an empty circle.

Figure 1 Frames

You can do the following with frames or keyframes:

• Insert frames, keyframes, and blank keyframes.

• Remove frames, keyframes, and blank keyframes.

• Convert frames to keyframes or blank keyframes.

• Drag frames and keyframes to a new location on the same layer or on a different layer.

• Copy and paste frames and keyframes.

Blank keyframe

End of keyframe spanStatic keyframe

Property keyframe in 
a classic tween

Property keyframe in 
a motion tween
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Representing animations in the timeline

Flash distinguishes tweened animation from frame-by-frame animation in the timeline by displaying different 
indicators in each frame that contains content. The following frame content indicators appear in the timeline:

A span of frames with a blue background indicates a motion tween (Figure 2). A black dot in the first frame of the 
span indicates that the tween span has a target object assigned to it. Black diamonds indicate the last frame and any 
other property keyframes. Property keyframes are frames that contain property changes explicitly defined by you. By 
default, Flash displays all types of property keyframes. All other frames in the span are interpolated by Flash, 
depending on the properties changed in these keyframes. A ball that moves across the Stage, for example, might have 
an initial keyframe that positions it on the left of the Stage, and another keyframe that positions it on the right. All 
other positions of the ball—moving from left to right—are interpolated in the frames between the two keyframes.

Figure 2 Motion tween

A hollow dot in the first frame indicates that the target object of the motion tween has been removed. The tween span 
still contains its property keyframes and can have a new target object applied to it (Figure 3).

Figure 3 Blank target frame

A span of frames with a green background indicates an inverse kinematics (IK) pose layer (Figure 4). Pose layers 
contain IK armatures and poses. Each pose appears in the timeline as a black diamond. Flash interpolates the 
positions of the armature in the frames between poses.

Figure 4 Inverse Kinematic (IK) pose layer

A black dot at the beginning keyframe, with a black arrow and blue background, indicates a classic tween (Figure 5).

Figure 5 Classic tween

A dashed line indicates that a classic tween is broken or incomplete, such as when a final keyframe is missing 
(Figure 6).

Figure 6 Broken or incomplete classic tween

A black dot at the beginning keyframe with a black arrow and a light green background indicates a shape tween 
(Figure 7).

Figure 7 Shape tween
Understanding frames and keyframes © 2012 Adobe Systems Incorporated
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A black dot indicates a single keyframe containing content. Light gray frames after a single keyframe contain the 
same content with no changes. These frames have a vertical black line and a hollow rectangle at the last frame of the 
span (Figure 8).

Figure 8 Continuous span of the same content

A small “a” indicates that the frame is assigned a frame action in the Actions panel (Figure 9). 

Figure 9 Frame action

A red flag indicates that the frame contains a label (Figure 10).

Figure 10 Frame labels

A green double slash indicates that the frame contains a comment (Figure 11).

Figure 11 Frame comment

A gold anchor indicates that the frame is a named anchor (Figure 12).

Figure 12 Named anchor
© 2012 Adobe Systems Incorporated Understanding frames and keyframes 3
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How to create animations

Overview of tweening

A tween is an animation you create by specifying a value for an object property in one frame and another value for 
that same property in another frame. Adobe Flash Professional calculates the values for that property between those 
two frames. The term “tween” comes from the phrase “in between.” You can tween movie clip, graphic, and button 
symbols and text fields.

A tween span is a group of frames in the timeline in which an object on the Stage can have one or more properties 
changed over time. A tween span appears in the timeline as a group of frames in a single layer with a blue or green 
background. You can select a tween span as a single object and drag it from one location in the timeline to another, 
including to another layer. Only one object on the Stage can be animated in each tween span. This object is called the 
target object of the tween span.

A property keyframe is a frame within a tween span where you explicitly define one or more property values for the 
tween target object. Each property you define has its own property keyframes. If you set more than one property in a 
single frame, the property keyframes for each of those properties reside in that frame. You can view each property of 
a tween span and its property keyframes in the Motion Editor. You can also choose which types of property 
keyframes to display in the timeline from the tween span context menu.

Beginning with Adobe Flash Professional CS4, the concepts of keyframe and property keyframe differ from earlier 
versions of Flash. The term keyframe refers to a frame in the timeline in which a change occurs, such as a symbol 
instance appearing on the Stage for the first time. The term property keyframe, new to Flash CS4, refers to a value 
defined for a property at a specific time or frame in a motion tween.

Types of Flash Animation

Motion tweens: Set properties for an object, such as position and alpha transparency in one frame and again in another 
frame, and Flash interpolates the property values of the frames in between. Motion tweens are useful for animation 
that consists of continuous motion or transformation of an object. Motion tweens appear in the timeline as a 
contiguous span of frames you can select as a single object by default. Motion tweens are powerful and simple to 
create.

Shape tweens: Draw a shape at one frame in the timeline and change that shape or draw another shape at another 
frame. Flash then interpolates the intermediate shapes for the frames in between, creating the animation of one shape 
morphing into another.

Classic tweens: Classic tweens are similar to motion and shape tweens, but you can create some specific animated 
effects not possible with span-based tweens. For example, you can apply eases to the groups of frames between the 
keyframes within the tween instead of across the entire length of a tween span. (To ease only specific frames of a 
motion tween, you must create a custom ease curve.) You can also use classic tweens to animate between two color 
effects, such as tint and alpha transparency, while motion tweens can apply only one color effect per tween.

Inverse kinematic (IK) poses: You can stretch and bend shape objects and link groups of symbol instances to make 
them move together in naturalistic ways. If you position the shape object or linked instances in different ways in 
separate frames, Flash interpolates the positions in the frames in between. Inverse kinematics poses help make 
character animation quick and easy.

Note: You will learn more about how to use inverse kinematic poses in the “How to create character animations” 
guide.

Motion tweens

You apply motion tweens only to symbol instances and text. All other objects must be converted to symbols before 
you can animate them by using a motion tween. 
© 2012 Adobe Systems Incorporated How to create animations 1
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A motion tween begins with a target symbol instance in the first keyframe of the tween span. You create motion by 
adding a property keyframe somewhere later in the timeline and changing the symbol properties, such as position, 
scale, or rotation. You can edit the individual properties of each symbol instance by using the Properties panel or the 
Motion Editor. You can also drag a symbol instance to a new location on the Stage or manipulate it by using the Free 
Transform tool. 

Note: A tween span can have only one target object. If you add a second symbol to a tween span, the new symbol 
replaces the original one. That means you can deliberately replace the target object of a tween by dragging a different 
symbol from the library onto the tween span in the timeline. 

To create a motion tween:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. Draw a shape on the Stage.

The shape appears in keyframe 1 of Layer 1.

3. Using the Selection tool (Figure 1), double-click to 
select the shape fill and stroke, if present. 

4. Choose Modify > Convert To Symbol. 

The Convert To Symbol dialog box appears (Figure 2).

Note: Applying a motion tween to a shape automatically 
converts the shape to a symbol.

5. Type a new name for the symbol in the Name text box, 
select Graphic for Type, and click OK (Figure 2).

6. Select frame 10.

7. Select Insert > Timeline > Frame. (The motion tween will 
last for 10 frames.)

When you insert a frame, Flash fills the area between the 
last frame (on the current layer) and the new frame with 
the same content (Figure 3). Frames 1 through 10 all 
contain the new symbol.

8. Make sure frame 10 (the end frame for the motion tween) 
is selected and select Insert > Motion Tween.

9. With frame 10 still selected in the timeline, select the 
symbol on the Stage (with a single click). Make one or 
more of the following changes:

Color change: In the Properties panel, select Tint from 
the Color Effect Style menu. Select 100% for the Tint 
Amount and change the color in the Tint Color box 
(Figure 4).

Fading: In the Properties panel, select Alpha from the 
Color Effect Style menu. Reduce the percentage of the 
Alpha Amount for more transparency. For example, an 
Alpha value of 0% makes the object disappear.

Position: Use the Selection tool to move the object to a 
different position on the Stage. A motion path appears. 
The points on this motion path are editable.

Figure 1 Tools panel

Figure 2 Convert To Symbol dialog box

Figure 3 Inserted frame

Figure 4 Properties panel

Selection tool
How to create animations © 2012 Adobe Systems Incorporated
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Size: Select the object. Then select Modify > Transform > 
Free Transform. Drag the object handles to increase size, 
decrease size, or rotate the object.

10. Click away from the symbol on the Stage to deselect it 
and select frame 1 in the timeline. 

In the timeline, the motion tween is represented by a solid 
blue background running from the start keyframe to the 
end keyframe (Figure 5). When you changed the 
properties of the symbol in frame 10, frame 10 was 
automatically converted to a property keyframe.

With the target object selected in frame 1, the tween’s 
properties appear in the Properties panel (Figure 6).

11. Adjust one or more properties of the motion tween in the 
Properties panel.

• Ease: Controls how fast the object starts or ends the 
motion tween. For example, a high number makes an 
object begin tweening quickly and end slowly.

• Rotate: Rotates the object clockwise or 
counterclockwise a designated number of times.

• Path: If you add a guide layer, the object is linked to 
the path drawn on the guide layer.

• Sync Graphic Symbols option: Starts and stops the 
tweening of all objects on the Stage at the same time.

12. Select the Motion Editor panel (Figure 7).

You can view and adjust all tween properties and 
property keyframes in the Motion Editor. 

• You can add or remove property keyframes for 
individual properties.

• You can move property keyframes to different 
frames within the tween.

• You can add or remove filters or color effects and 
adjust their settings.

• You can add different preset eases to individual 
properties and property categories.

• You can create custom ease curves.

• You can enable roving for individual property 
keyframes for X, Y, and Z properties. Roving allows 
the property keyframe to move to different frames or 
between individual frames to create smooth motion.

Figure 5 Motion tween in the timeline

Figure 6 Motion tween properties

Figure 7 Motion Editor panel
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13. Select Control > Test Movie > In Flash Professional to 
test the movie.

14. Select File > Close to close the preview window.

15. Select the Timeline panel.

16. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline panel 
(Figure 8).

17. Drag the onion skinning frame handles (they appear as 
brackets with circles on them at the top of the timeline) to 
span the frames in which the object appears.

All the intermediate steps of the tween are visible on the 
Stage (Figure 9).

18. Turn off onion skinning by clicking the Onion Skin 
button again.

19. Save the movie.

Figure 8 Onion Skin button (shown selected)

Figure 9 Onion skinning visible

Shape tweens

In shape tweening, you draw a vector shape at one specific frame in the timeline and change that shape or draw 
another shape at another specific frame. Flash then interpolates the intermediate shapes for the frames in between, 
creating the animation of one shape morphing into another.

Note: Shape tweens work best with simple shapes. Avoid shapes with cutouts or negative spaces in them. Experiment 
with the shapes you want to use to determine the results. You can use shape hints to tell Flash which points on the 
beginning shape should correspond to specific points on the end shape. Shape tweens can use much more computer 
memory than motion tweens, so it is best to use shape tweens sparingly.

Onion Skin button
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To create a shape tween:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

Frame 1 in Layer 1 already contains a blank keyframe.

2. Begin by adding a shape to the Stage:

Drawn objects: Select a shape tool (Rectangle, Oval, or 
PolyStar) and draw a shape on the Stage.

Text: Select the Text tool and type a word or phrase on 
the Stage. Then select the text and select Modify > Break 
Apart. This breaks the words into separate letters. With 
the letters still selected, select Modify > Break Apart 
again to convert the letters into shapes.

Outside images: Select File > Import > Import To Stage 
to import an image. If the image is a bitmap, you must 
break it apart. If the image is a grouped vector drawing, 
you must ungroup it completely. To break apart a bitmap, 
select Modify > Break Apart. To ungroup an image, 
select Modify > Ungroup.

Note: You might need to select Modify > Break Apart or 
Modify > Ungroup multiple times until the object 
becomes a shape, as indicated in the Properties panel.

3. Using the Selection too, select frame 10.

4. Select Insert > Timeline > Keyframe.

The tween will last for 10 frames.

5. Make sure frame 10 is still selected and make one or 
more of the following changes to your shape:

Amorphous shape change: Click the Stage with the 
Selection tool to deselect the object. Bring the Selection 
tool close to the object to grab an edge (Figure 10). Drag 
the edge to modify the shape (Figure 11). The result is an 
amorphous shape change (Figure 12).

Different shape: To morph between your original shape 
and a new object, delete the object in keyframe 10 and 
draw a new object.

Note: Select Modify > Break Apart if the drawn object is 
not a shape.

Text: To morph between your original shape and some 
text, delete the object in keyframe 10 and type the text on 
the Stage. Select Modify > Break Apart until the text 
block is a shape, as indicated in the Properties panel.

Outside image: To morph between your original shape 
and a new image you import, delete the object in 
keyframe 10 and select File > Import to bring in the 
outside image. Select Modify > Break Apart to make the 
object a shape, as indicated in the Properties panel.

Figure 10 Select an edge of the shape

Figure 11 Drag to modify the shape

Figure 12 Amorphous shape change
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6. Click anywhere inside the tween span on the timeline and 
select Insert > Shape Tween.

Green shading with an arrow between keyframes 
indicates a shape tween span (Figure 13).

7. Select frame 1 on the timeline (on the current layer).

This is the start frame for the animation.

8. In the Tweening section of the Properties panel, adjust 
one or more properties of the Shape tween (Figure 14):

Ease: Controls how fast the object starts or ends the 
shape tween. For example, a high number begins the 
tweening quickly and ends slowly.

Blend (Distributive): Creates an animation in which the 
intermediate shapes are smoother and more irregular.

Blend (Angular): Creates an animation that preserves 
corners and straight lines in the intermediate shapes.

9. Select Control > Test Movie > In Flash Professional to 
test the movie.

10. Close the preview window.

11. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline panel.

12. Drag the frame handles (they appear as brackets with 
circles on them at the top of the timeline) to span the first 
10 frames of Layer 1.

The steps of the tween are all visible on the Stage.

13. Turn off onion skinning by clicking the Onion Skin 
button again.

Figure 13 Shape tween span

Figure 14 Properties panel

Classic tweens

In classic tween animation, you define keyframes at points in the animation and Flash creates the contents of the 
frames in between. The interpolated frames of a classic tween animation appear as light blue shading with an arrow 
drawn between keyframes. Because Flash documents save the shapes in each keyframe, create keyframes only at 
those points in the artwork where something changes.

You can create certain types of animated effects by using classic tweens that not possible with motion tweens.

• Add animation to symbol instances, object groups, or text

• Add timeline effects

• Paste motion tween properties

• Apply custom ease-in/ease-out settings

Note: Advanced uses of classic tweens, such as those listed here, will be dealt with in greater detail in Project 6. The 
following exercise outlines the steps for creating a simple classic tween, which serves as a basic introduction to 
classic tweening and the procedural differences between classic and motion tweening.
How to create animations © 2012 Adobe Systems Incorporated
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To create a classic tween:

1. Start Flash and open a blank document 
(ActionScript 3.0). 

Frame 1 in Layer 1 already contains a blank keyframe.

2. Begin by adding a symbol to the Stage.

Note: You may need to add a shape, image, or text first 
and convert the object to a new symbol.

3. Select frame 10.

4. Select Insert > Timeline > Keyframe.

The tween will last for 10 frames (Figure 15).

5. Make sure frame 10 is still selected and move the symbol 
to a new position on the Stage.

6. Click between frames 1 and 10 in the timeline and select 
Insert > Classic Tween. 

The classic tween appears as light blue with an arrow 
(Figure 16).

7. Select frame 1 on the timeline (on the current layer).

This is the start frame for the animation.

8. Adjust the position, color, or scale of the symbol in the 
starting keyframe.

9. Select frame 10, and adjust the position, color, or scale of 
the symbol to be as you want the animation to end.

10. Select Control > Test Movie > In Flash Professional to 
test the movie.

11. Close the preview window.

Figure 15 Start and end keyframes

Figure 16 Classic tween span
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How to draw and create shapes
You can add artwork to your Adobe Flash Professional documents in two ways: You can import images or draw 
original artwork in Flash by using the drawing tools in the Tools panel. 

Drawings you create in Flash are vector graphics. Vector graphics describe images by using lines and curves called 
vectors that also include color and position properties. When you edit a vector graphic, you modify the properties of 
the lines and curves that describe its shape. You can move, resize, reshape, and change the color of a vector graphic 
without changing the quality of its appearance. Vector graphics are resolution independent; that is, they can be 
displayed on output devices of varying resolutions without losing any quality. 

The files you import to Flash can be either vector graphics or bitmap images. Bitmap images (also known as raster 
images) are made up of pixels in a grid. Pixels are picture elements: tiny dots of individual color that make up what 
you see on your screen. A JPEG photograph is an example of a bitmap image. Because bitmaps are resolution 
dependent, it's difficult to increase or decrease their size without losing some image quality. Bitmap images are 
typically much larger in file size than vector graphics. 

The bitmap images you import to Flash can also be turned into vector drawings in two ways: You can break them 
apart to create a single vector shape or you can trace the bitmap to create a collection of vector shapes that resemble 
the original bitmap image.

In this guide you use the drawing tools to create and modify vector graphics. You also import bitmap images and 
convert them to vector shapes by using the Break Apart and Trace Bitmap commands.

Drawing with basic lines and shapes

One way to become familiar with the Flash drawing tools is to create something simple using basic lines and shapes.

Flash has two drawing modes: Merge Drawing and Object Drawing. Merge Drawing blends shapes when they 
overlap on the Stage. Shapes drawn on top of other shapes will merge, which means if you select one of the shapes 
and move it, the underneath shape is cut away (Figure 1).

Object drawing treats your shapes as grouped objects that can overlap without affecting each other (Figure 1). 

You can change between drawing modes by enabling or disabling Object Drawing in the Tools panel.

Figure 1 Merge Drawing (left) and Object Drawing (right)

Selecting drawing tools and setting properties

Flash drawing tools are available in the Tools panel. When you select a drawing tool, the properties for that tool 
appear in the Properties panel and any options for the selected tool appear at the bottom of the Tools panel. (You may 
need to enlarge the Flash window to see tool options.)

Most drawing tools have several properties in common, but each tool has a few unique properties.
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To set drawing tool properties:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. Select the Oval tool in the Tools panel.

The Oval tool properties appear in the Properties panel 
(Figure 2). If the Properties panel isn’t open, select 
Window > Properties.

In the Properties panel, you can set the color, style, and 
size of the outer stroke of a shape. You can also change 
the color of the shape’s inner fill. 

You can select from several stroke types, such as solid or 
dashed lines.

Selecting the Hinting option enables stroke hinting. 
Stroke hinting adjusts line and curve anchors on full 
pixels to prevent blurry vertical or horizontal lines.

Cap settings control how the end of a path appears.

• None: The path ends flush—there is no cap.

• Round: Adds a round cap that extends beyond the 
path end by half the stroke width.

• Square: Adds a square cap that extends beyond the 
path end by half the stroke width.

Join settings define how two path segments meet 
(Figure 3). 

• Miter: Forms a sharp angle at the junction of two 
paths. To avoid beveling a mitered corner, enter a 
Miter value greater than 0.

• Round: Creates a smooth, rounded connection 
between two paths. 

• Bevel: Creates a beveled edge where two paths meet. 

The options in the Properties panel are slightly different 
for each drawing tool. For example, the Oval tool 
includes Start Angle, End Angle, and Inner Radius 
properties. 

The Rectangle tool includes Corner Radius properties for 
creating rounded corners (Figure 4).

If you are creating lines with the Brush tool or with the 
Pencil tool in Smooth mode, you can set the Smoothing 
value (Figure 5). Smoothing controls how Flash smooths 
out the curves in the lines you draw or paint. You can 
specify a value from 0 to 100. 

Figure 2 Properties panel, Oval tool

Figure 3 Join options (left to right): Miter, Round, 
Bevel

Figure 4 Rectangle tool corner radius options

Figure 5 Pencil and Brush tool Smoothing option

Stroke color Fill colorHinting option
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3. Make sure the Oval tool is still selected.

A tool’s modifier options are located in the options area 
at the bottom of the Tools panel (Figure 6). You may 
need to enlarge the Flash window to see tool options.

Options that are common to most Flash shape-drawing 
tools include:

• Stroke Color and Fill Color: Open a color palette 
to change stroke or fill color. In Merge Drawing 
mode, you must select a color before you begin 
drawing. You can also select stroke and fill colors 
in the Properties panel. 

• Black And White: Resets the stroke and fill colors 
to black stroke and white fill.

• Swap Colors: Swaps the current stroke and fill 
colors.

• Object Drawing: Toggles Object Drawing mode 
on and off. This is how you change between Merge 
Drawing and Object Drawing.

• Snap To Objects: Toggle the Snap To Objects 
feature on and off. This is off by default.

Figure 6 Tools panel, Oval tool modifier options

Creating a simple drawing with lines and shapes

A good way to become familiar with the Flash drawing tools is to create something very basic. In this activity, you 
use lines and shapes to create a simple drawing.

To draw in Merge Drawing mode:

1. Select the Oval tool in the Tools panel (if it’s not 
already selected). 

2. In the options section of the Tools panel, make sure 
Object Drawing is deselected.  

For now, you want to be in Merge Drawing mode.

3. Select a fill color for the shape, such as blue.

Note: You can select a fill color in the Properties panel 
or in the Tools panel.

4. Select a stroke color, such as black.

5. In the Properties panel, change the Stroke Height value 
to 15.

6. On the lower-center of the Stage, drag to draw an oval 
that is about 2 inches tall (Figure 7). 

Note: If you want to draw a perfect circle, hold down 
Shift as you drag the Oval tool on the Stage.

Figure 7 Oval shape with stroke and fill

Stroke color

Fill color

Black And White

Swap Colors

Object Drawing

Snap To Objects
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7. In the Properties panel, change the Oval tool fill color, 
perhaps to red.

8. Hold down Shift and drag on the Stage to create a perfect 
circle. Make it about the same size as the first oval and be 
sure the two shapes do not touch or overlap (Figure 8).

Note: If you make a mistake or don’t like what you’ve 
drawn, press Ctrl+Z (Windows) or Command+Z (Mac 
OS) to undo your drawing and start over.

9. Use the Selection tool to click the outline (stroke) of the 
top circle.

Only the outer stroke is selected.

10. Click the center (fill) of the top circle to select it.

Now only the fill is selected.

11. Double-click the fill of the top circle. 

The entire object (stroke and fill) is selected.

Note: If you double-click the stroke, only the stroke is 
selected. To select both the stroke and fill, you must 
double-click the fill.

12. With the top circle selected, drag it to the top portion of 
the bottom circle (Figure 9). 

13. Click away from the shapes to deselect them and then 
click once in the center of the top circle to select only its 
fill.

14. Press the Delete key.

Because you are drawing in merge mode, the selected fill 
disappears along with everything below it (Figure 10).

Next you draw in Object Drawing mode.

Figure 8 Two shapes with different fills

Figure 9 Drag to overlap the shapes

Figure 10 Merged shapes
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To draw in Object Drawing mode:

1. Select the Oval tool and then select the Object Drawing 
modifier in the options section at the bottom of the Tools 
panel (Figure 6).

2. Change the stroke color to light blue and the fill color to 
black. Change the Stroke Height value to 10.

3. Anywhere on the Stage, Shift-drag to draw a small circle 
in Object Drawing mode (Figure 11).

In Object Drawing mode, the shape’s stroke and fill are 
grouped as one object and share the same selection box. 

4. Use the Selection tool to select the circle you just drew, 
and in the Properties panel, change the Width (W) and 
Height (H) values to approximately 25 (Figure 12).

Note: You can click the Lock Width And Height Values 
Together option to constrain or unconstrain the height 
and width of the shape (Figure 12). 

5. With the small blue and black circle still selected, 
select Modify  > Convert to Symbol.

The Convert To Symbol dialog box appears (Figure 13).

6. Type blue_eye for Name, choose Graphic as the symbol 
Type, and click OK.

7. Open the Library panel, and drag another instance of the 
eye symbol to the Stage.

8. Use the Selection tool to drag both instances of the eye 
symbol into the empty space in the top circle shape 
(Figure 14).

You can place Object Drawings or symbols over other 
shapes without affecting the underlying shape.

One you place a symbol on the Stage, you can swap it for 
another symbol in the library. You do that next.

Figure 11 Small circle created in Object Drawing 
mode

Figure 12 Properties panel, Position And Size

Figure 13 Convert To Symbol dialog box

Figure 14 Shapes converted to symbols

Lock Width And Height Value 
Together option
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To swap symbol instances:

1. Create another small eye shape, only this time make the 
stroke color green. 

2. Convert the green eye shape to a new graphic symbol 
named green_eye.

Now you can create some characters with blue eyes and 
others with green eyes.

3. Use the Selection tool to select one of the blue_eye 
symbols on the Stage. 

4. In the Properties panel, click Swap (Figure 15).

The Swap Symbol dialog box appears (Figure 16).

5. Select the green_eye symbol in the Swap Symbol dialog 
box and click OK.

You have swapped the symbol on the Stage. Your 
character has one green eye and one blue eye 
(Figure 17).

6. Swap the other eye with a green eye so they match.

Next you use PolyStar tool to create a nose.

Figure 15 Properties panel, Swap button

Figure 16 Swap Symbol dialog box

Figure 17 Swapped symbols on the Stage
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To draw polygons and stars:

1. Select > Edit > Deselect All to make sure nothing is 
selected on the Stage.

2. Select the PolyStar tool in the Tools panel.

Note: The PolyStar tool shares the same space in the 
Tools panel as the Rectangle and Oval tools.

3. Open the Properties panel and change the fill color to 
black and the stroke color to None. 

Note: To set a stroke or fill color to None, click the color 
swatch in the Properties panel or in the Tools panel to 
open the color palette and click the None option 
(Figure 18). 

4. In the Tool Settings section of the Properties panel, click 
Options.

The Tool Settings dialog box appears (Figure 19). You 
can create polygons or stars.

5. In the Style menu, choose Polygon. Set the number of 
sides to 3 (to create a triangle), and click OK.

6. Drag to draw a triangle with one vertex pointing down 
(Figure 20).

7. In the Tools panel, select the Free Transform tool.

Free Transform selection handles appear around the 
selected shape (Figure 21).

8. Position the pointer over the lower-right selection handle 
of the triangle shape, and drag inward to reduce the size 
of the shape (Figure 21).

Note: You can hold down Shift as you drag to constrain 
the proportions of the shape. You can also resize the 
shape by entering Width (W) and Height (H) values in 
the Properties panel.

9. Use the Selection tool to select and drag the triangle 
below the eyes in your drawing (Figure 22).

Next you use the Line tool to create a mouth.

Figure 18 Stroke color palette

Figure 19  Tool Settings dialog box

Figure 20  Polygon shape

Figure 21  Free Transform selection

Figure 22  Position the triangle to create a nose

None
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To draw paths by using the Line, Pencil, and Brush tools:

1. Select the Line tool in the Tools panel.

2. In the Properties panel, select a stroke color and change 
the stroke height to 4.

3. Drag to draw a horizontal line below the triangle you just 
created (Figure 23).

4. Use the Selection tool to click an empty area of the Stage 
to deselect the line without selecting another shape.

5. Position the pointer along the bottom edge of the line and 
drag downward to modify the line (Figure 24).

6. Select the Brush tool in the Tools panel.

Notice the stroke options are disabled for the Brush tool 
in the Properties panel.

7. Select a fill color for the Brush tool in the Properties 
panel.

You can set painting options for the brush in the options 
section of the Tools panel (Figure 25).

• Object Drawing Mode: Toggle Object Drawing 
Mode on or off. 

• Lock Fill: When you select the Lock Fill modifier 
with the Brush or Paint Bucket tool and paint with 
the tool, the bitmap or gradient fill extends across the 
objects you paint on the Stage. 

• Brush Mode: Select from five painting modes.

• Paint Normal: Paints over lines and fills on the 
same layer.

• Paint Fills: Paints fills and empty areas, leaving 
lines unaffected.

• Paint Behind: Paints in blank areas of the Stage 
on the same layer, leaving other lines and fills 
unaffected.

• Paint Selection: Applies a new fill to the 
selection when you select a fill in the Fill Color 
control or the Fill box in the Properties panel, 
the same as selecting a filled area and applying a 
new fill.

• Paint Inside: Paints the fill in which you start a 
brush stroke and never paints lines. If you start 
painting in an empty area, the fill doesn’t affect 
any existing filled area.

• Brush Size and Brush Shape: Select a size and shape 
for the brush.

Figure 23  Position the triangle to create a mouth

Figure 24  Reshape the line to make a smile

Figure 25  Brush modifiers in the Tools panel

Lock Fill

Brush Size

Brush Mode

Brush Shape

Object Drawing Mode
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8. Experiment with the Brush tool by making several brush 
strokes on the Stage. 

In this example, we used the Brush to make antennae for 
the bug-like character who has been taking shape 
throughout this activity (Figure 26).

9. Select the Pencil tool in the Tools panel.

Notice the fill color option is disabled for the Pencil tool 
in the Properties panel.

10. Select a stroke color and set a stroke height for the Pencil.

Flash offers three pencil drawing modes, available in the 
options section of the Tools panel.

• Straighten: Draws straight line segments.

• Smooth: Draws curvy lines with smooth curves.

• Ink: Draws freehand lines with no modification 
applied.

11. Use the Pencil tool to put some final touches on your 
drawing (Figure 27). 

Note: Because you are still in Object Drawing mode, 
overlapping your existing shapes will not affect them.

Now you’ve created your entire character and have 
several shapes arranged on the stage.

Figure 26  Brush strokes used to create antennae

Figure 27  Smooth pencil lines used to create arms 
and legs
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Creating decorative fills by using the Deco tool

Designing the settings in a Flash movie or the virtual world in a game can be similar to designing sets or locations in 
a live-action movie. You don’t need to be a fine artist to include stylish backgrounds in Flash. By using the Deco 
(decorative) tool with its various drawing effects, you can turn symbols into complex geometric patterns with creative 
artistic fills.

Some Deco tool drawing effects, such as the Tree Brush or Lightning Brush, do not use symbols. Other Deco tool 
drawing effects, such as Grid Fills, require that you select a symbol in the document library to use as the artwork for 
the decorative fill.

The Symmetry effect

Use the Deco tool Symmetry effect to arrange symbols symmetrically around a central point.

To apply the Symmetry effect:

1. Open a Flash document that contains symbols or open a 
new blank Flash document (ActionScript 3.0) and use the 
shape tools to create a few new graphic symbols. 

Note: Smaller symbols work best when you are creating 
decorative fills. 

2. Select the Deco tool in the Tools panel.

Properties for the Deco tool appear in the Properties 
panel (Figure 28).

3. Select Symmetry Brush from the Drawing Effect menu in 
the Properties panel (Figure 29).

4. In the Properties panel, click the Edit button.

The Select Symbol dialog box appears. It shows the 
symbols in the library (Figure 30).

You can use any movie clip or graphic symbol in the 
library with the Symmetry Brush effect. This symbol-
based effect gives you a great deal of creative control 
over artwork you create in Flash.

5. Select one of the symbols you created and click OK.

Figure 28 Properties panel, Deco tool

Figure 29 Drawing Effect menu

Figure 30 Select Symbol dialog box

Deco tool
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6. In the Properties panel, choose one of the options from 
the Advanced Options menu (Figure 31). 

• Reflect Across Line: Flips the shapes an equal 
distance apart across an invisible line that you 
specify.

• Reflect Across Point: Places two shapes an equal 
distance apart around a fixed point that you specify.

• Rotate Around: Rotates the shapes in the symmetry 
around a fixed point that you designate. The default 
reference point is the center point of the symmetry. 
To rotate the object around its center point, drag in a 
circular motion.

• Grid Translation: Creates a grid by using the shapes 
in the Symmetry effect you are drawing. Each click 
of the Deco tool on the Stage creates a grid of 
shapes. Adjust the height and width of the shapes by 
using the x and y coordinates defined by the 
Symmetry Brush handles.

7. Click the Stage where you want the Symmetry Brush 
artwork to appear (Figure 32).

8. Use the Symmetry Brush handles to adjust the size of the 
symmetry and the number of symbol instances. 

9. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 31 Advanced Options menu

Figure 32 Placing symbols with the Symmetry 
Brush
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The Grid Fill effect

You can use the Grid Fill effect to fill the Stage, a symbol, or a closed region with a symbol from the library. After 
you draw a Grid Fill on the Stage, if you move or resize the filled symbol, the Grid Fill moves or resizes accordingly.

The Grid Fill effect creates a repeating tiled background or an area or shape with a custom pattern. The default 
symbol for the Grid Fill effect is a 25-by-25-pixel black rectangular shape with no stroke.

To apply the Grid Fill effect:

1. Select the Deco tool, and select Grid Fill from the 
Drawing Effect menu in the Properties panel (Figure 33).

You can use any movie clip or graphic symbol in the 
library with the Grid Fill effect. You can use the same 
symbol for all tiles or combine up to four symbols. The 
default shape is a small black square. You an change the 
color used for the default shape by clicking the color 
swatch for each tile and picking a new color.

2. In the Properties panel, click the Tile 1 Edit button to 
select a symbol from the library.

The Select Symbol dialog box appears, listing symbols in 
the document library.

3. Select a symbol in the Select Symbol dialog box and 
click OK.

You can use the following advanced options in the 
Properties panel to specify the horizontal and vertical 
spacing and the scale of the fill shape.

• Horizontal Spacing: Specifies the horizontal 
distance in pixels between shapes used in the Grid 
Fill.

• Vertical Spacing: Specifies the vertical distance in 
pixels between shapes used in the Grid Fill.

• Pattern Scale: Enlarges or shrinks an object 
horizontally (along the x axis) and vertically (along 
the y axis).

After you apply the Grid Fill effect, you cannot change 
the advanced options to alter the fill pattern.

4. Click the Stage or click within a shape or symbol where 
you want the Grid Fill pattern to appear.

The pattern fills the area (Figure 34). If you want the 
entire grid filled with the same symbol, select that 
symbol for all four tiles in the Properties panel.

5. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 33 Deco tool Grid Fill properties

Figure 34 Grid Fill pattern
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The 3D Brush effect

You can use the 3D Brush effect to spray symbols so they appear to be in front of each other. After you draw a 3D 
Brush on the Stage, if you resize or otherwise change the filled symbol, the 3D Brush changes accordingly.

To apply the 3D Brush effect:

1. Select the Deco tool, and select 3D Brush from the 
Drawing Effect menu in the Properties panel (Figure 35).

Similar to the Grid Fill effect, you can choose the 
symbols or default shapes to use when drawing.

2. In the Properties panel, click the Object 1 Edit button to 
select a symbol from the library.

The Select Symbol dialog box appears.

You can use any movie clip or graphic symbol in the 
library with the 3D Brush effect.

3. Select a symbol in the Select Symbol dialog box and 
click OK.

You can use the following advanced options in the 
Properties panel.

• Max Objects: Specifies the total number of shapes 
used in the 3D Brush.

• Spray Area: Specifies the area covered in each spray 
of the 3D Brush.

• Perspective: Specifies that objects appear in front of 
each other.

• Distance Scale: Specifies how far in front of each 
other objects appear to be.

• Random Scale Range: Specifies the degree to which 
objects vary in size.

• Random Rotation Range: Specifies the degree to 
which objects are rotated.

Note: After you apply the 3D Brush effect, you cannot 
change the advanced options to alter the fill pattern.

4. Drag the pointer across the Stage to draw with the 3D 
Brush (Figure 36).

As you drag, Flash paints a pattern using the objects you 
selected in the Properties panel. 

5. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 35 Deco tool 3D Brush properties 

Figure 36 Placing symbols with the 3D Brush 
effect
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The Vine Fill effect

You can use the Vine Fill effect to fill the Stage, a symbol, or a closed region with a vine-like pattern. You can 
substitute your own artwork for the leaves and flowers by selecting symbols from the library. The resulting pattern is 
contained in a movie clip that itself contains the symbols that make up the pattern.

To apply the Vine Fill effect:

1. Select the Deco tool, and select Vine Fill from the 
Drawing Effect menu in the Properties panel (Figure 37).

By default, the Vine Fill effect uses a leaf and flower as 
the artwork for the fill. You can change these to custom 
symbols by clicking the Edit buttons and selecting 
symbols in the document library.

You can set the following Advanced Options in the 
Properties panel:

• Branch Angle: Specifies the angle of the branch 
pattern.

• Branch Color: The color box to the right of Branch 
Angle. Specifies the color for the branch.

• Pattern Scale: Adjusts an object by enlarging or 
reducing it both horizontally (along the x axis), and 
vertically (along the y axis).

• Segment Length: Specifies the length of the 
segments between leaf and flower nodes.

• Animate Pattern: Specifies that each iteration of the 
effect is drawn to a new frame in the Timeline. This 
option creates a frame-by-frame animated sequence 
of the flower pattern as it is drawn.

• Frame Step: Specifies how many frames to span per 
second of the effect being drawn.

Note: After you apply the Vine Fill effect, you cannot 
change the advanced options in the Properties panel to 
alter the fill pattern.

2. Click the Stage or click within the shape or symbol where 
you want the Vine Fill pattern to appear.

The pattern fills the area (Figure 38).

3. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 37 Deco tool Vine Fill properties

Figure 38 Vine Fill pattern
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Converting text and bitmap images to vector shapes

In addition to drawing vector shapes in Flash, you can import bitmap graphics, such as photographs, and convert 
them to vector artwork. Converting large bitmaps to vectors can significantly reduce the file size of your document.

Flash provides two ways to convert a bitmap image to a vector shape: Break Apart converts the entire bitmap into a 
single shape. Trace Bitmap analyzes the colors in the bitmap image and creates a collection of merged shapes.

Using the Break Apart command

The Break Apart command appears in the Modify menu.

You can break apart bitmaps and text to create vector shapes. When you break apart text, you can use the resulting 
shape in an animation that morphs the shape into another shape. 

When objects or symbols are grouped, using Break Apart ungroups them into separate objects. You may need to use 
Break Apart several times to completely ungroup objects before you can convert them into vector drawings. 

To break apart text:

1. Use the Text tool to create some text. Use the Selection 
tool to select the text.

2. Select Modify > Break Apart.

The text is ungrouped into separate letters (Figure 39). 
You can now select and modify each letter as a separate 
object, but they are still not vector shapes, as shown in 
the Properties panel (Figure 41). You need to break them 
apart a second time to convert them to vector shapes.

3. Select Modify > Break Apart again.

Flash converts the selected letters into several shapes 
(Figure 40), as shown at the top of the Properties panel 
(Figure 41). 

4. Select Edit > Select All and press Delete. 

You will start the next activity with an empty Stage.

Figure 39 Text broken into separate objects

Figure 40 Letter objects broken into shapes

Figure 41 Properties panel, shape properties
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To break apart a bitmap image:

1. Select the bitmap you want to break apart.

Note: To import a bitmap image, you can choose File > 
Import > Import To Stage, select the file to import, and 
click Open. 

2. Select Modify > Break Apart.

Flash converts the bitmap image to a shape, as shown at 
the top of the Properties panel (Figure 42).

The selected image is filled with a consistent pattern to 
show it’s selected as a single shape object (Figure 43).

3. Click away from the shape or select Edit > Deselect All 
to deselect the shape.

4. Click the shape again to select it.

The entire shape is selected as a single object.

5. Select Modify > Combine Objects > Union.

The shape is grouped as a single drawing object, as 
shown in the Properties panel (Figure 44). You can now 
apply stroke and fill properties.

6. Select Edit > Select All and press Delete.

Figure 42 Properties panel, shape properties

Figure 43 Selected shape

Figure 44 Properties panel, drawing object
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Using Trace Bitmap

In this activity, you trace the same bitmap you broke apart in the previous activity to see the difference between Break 
Apart and Trace Bitmap.

To trace a bitmap image:

1. Select the bitmap you want to break apart.

Note: If you’ve already imported the image, you can drag 
a fresh copy of the image from the Library panel to the 
Stage. 

2. Select Modify > Bitmap > Trace Bitmap.

The Trace Bitmap dialog box appears (Figure 45). 
Tracing will occur based on colors and lines in the image. 
You can adjust how sensitive Flash is when analyzing the 
bitmap. 

3. Click OK to accept the default Trace Bitmap settings.

Flash traces the bitmap and creates an artistic rendering 
of the image. The resulting object is a vector shape, as 
shown in the Properties panel.

4. Click away from the image or select Edit > Deselect All 
to deselect the shape.

5. Click in the image again.

Only a portion of the image is selected (Figure 46). 
When you trace a bitmap, the resulting vector drawing is 
a collection of merged shapes.

Figure 45 Trace Bitmap dialog box

Figure 46 Traced bitmap converted to shapes
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Using adaptive scaling to produce a Flash document for multiple screens

It used to be that one of the most time-consuming tasks of designing content in Flash was to size and optimize your 
movie for multiple screen sizes. With Adobe Flash Professional, you can now choose to scale the contents of your 
document when you change the Stage size. All objects on the Stage, including symbols, shapes, paths, motion paths, 
and bitmap images across all scenes, are scaled together.

To scale a document by using adaptive scaling:

1. Select Modify > Document.

The Document Settings dialog box appears (Figure 47). 

When you change the Dimensions settings of the 
document, the Scale Content With Stage option becomes 
active. This option activates adaptive scaling.

2. To change the document dimensions, select Scale 
Content With Stage, and click OK.

The content resizes along with the Stage.

3. Select Edit > Undo Modify FLA Document to return the 
Stage and content to their original dimensions.

Figure 47 Document Settings dialog box
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How to work with text
Adobe Flash Professional lets you add text to a Flash application in two formats:

• You can add Text Layout Framework (TLF) text.

• You can add Classic text.

Using the Text Layout Framework

TLF text provides the following enhancements over Classic text:

• You can adjust a wider range of character aspects, such as leading and tracking.

• You can rotate text more easily.

• You can flow text across multiple containers, as it does in a magazine page layout.

• You can better control the attributes of Asian text.

• You can create right-to-left text.

The Text Layout Framework is available as an option in the Properties panel. 

TLF text requires that ActionScript 3.0 and Flash Player 10 or later are specified in the publish settings of your FLA 
file. See the guide “How to publish a Flash document” for more information about publish settings.

To create TLF text:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. Click the Text tool.

3. Make sure the Properties panel is open. If not, select 
Window > Properties.

4. Select TLF Text from the Text Engine menu (Figure 1).

5. Move the pointer to the Stage.

The pointer changes to a cross hair with the letter T 
attached to it.

6. Drag to create a container (Figure 2).

7. Release the mouse button and click in the container.

8. Type some text (Figure 3).

Figure 1 Text Engine menu.

Figure 2 Dragging to create a container

Figure 3 Text container
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Managing text flow for TLF text

If you fill a Flash TLF text container with more text than fits within the bounding box, a red plus symbol appears. 
This red plus indicates the text is overset. Overset text is text that does not fit in the container.You can solve the 
problem of overset text by making the container bigger, but often you will want to continue the text in another 
container, either on the same page or on another page. This is called text flow. 

For example, in Figure 4 the upper container is overset and needs to flow to the lower text container.

Figure 4 Overset text

In Figure 5, the two containers have been linked, as indicated by a line between the Out port of the top container and 
the In port of the bottom container.

Figure 5  Linked containers

Out port of text container In port of text container
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To flow text:

1. Use the Selection tool to select a container.

2. Click the Out port in the lower-right corner of the 
selected container.

The pointer changes to the loaded text icon, an arrow 
with small lines of text (Figure 6).

3. Then do one of the following:

• To link to an existing container, position the pointer 
over the target container. The pointer changes to the 
link text icon, an arrow with chain links (Figure 7). 
Click the container to link the two containers.

• To link to a new container, click or drag on an empty 
part of the Stage. Clicking creates an object of the 
same size and shape as the original; dragging lets 
you determine the size of the container.

The containers are now linked and text will flow between 
them (Figure 8).

Figure 6 Loaded text icon

Figure 7 Link text icon

Figure 8 Result of linking to a text container
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Using Classic text

You can specify three types of Classic text in the Properties panel: Static, Dynamic, and Input. The default type is 
Static. Use Static text when the text will not change, such as button and form labels. Use Dynamic text for text that 
will change as the movie plays, such as text pulled from an external database in response to a viewer’s request. Use 
Input text for requesting input from the viewer, such as a user name and password—input text is similar to a form 
field.

To use Classic text:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. In the Tools panel, select the Text tool.

3. Make sure the Properties panel is open. If not, select 
Window > Properties.

4. Select Classic Text from the Text Engine menu 
(Figure 9).

5. In the Properties panel, make sure that Static Text is 
selected in the Text Type menu (Figure 9).

6. Move the pointer to the Stage.

The pointer changes to a cross hair with the letter T 
attached to it.

7. To create an expanding-width text field, click on the 
Stage.

The text field contains a flashing insertion point. This is 
where text appears as you type. The round handle 
indicates the text field is an expanding-width one-line 
static text field (Figure 11).

8. Type the text.

The text field expands as you type.

9. Click away from the text to deselect it.

10. To create a fixed-width text field, drag on the Stage to 
create a text box. Make the box about as wide as you 
think is necessary to fit your text.

A text field is created. This text field has a square handle 
in the upper right corner (Figure 12). The square handle 
indicates that the text field is a fixed-width static text 
field.

Figure 9 Text Engine menu

Figure 10 Text Type menu

Figure 11 Expanding-width one-line static text 
field

Figure 12 Fixed-width static text field

Round handle

Square handle
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11. Type the text.

The text you type wraps to a new line when it reaches the 
right edge of the text field.

12. Drag the square handle to the right until the text is on a 
single line.

Note: Double-clicking a square handle changes it to a 
round handle and changes the text field to an expanding-
width one-line static text box.

13. Click away from the text to deselect it.

Formatting both TLF and Classic text

You can apply basic character formatting to TLF or Classic text, such as font family, font type, font style, and font 
color. You can also adjust tracking, adjust leading, and apply anti-aliasing to both formats.

To apply basic formatting to text:

1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic). 

2. In the Character section of the Properties panel, choose a 
different font family in the Font Family menu, such as 
Verdana (Figure 13).

3. Choose a different font style, such as italic or bold.

4. Set a different font size, such as 14, by using the Size 
scrubber. (You can also click the scrubber and type a 
value for Size.).

5. Choose a different font color by clicking the Color box 
and doing one of the following:

• Select a color from the Color palette (Figure 14).

• Enter a hexadecimal color value in the upper-left 
corner (Figure 14).

• Click the Color Picker icon and select a color from 
the system color picker. (When setting the text color, 
use only solid colors, not gradients. To apply a 
gradient to text, break the text apart and convert the 
text to its component lines and fills.)

6. In the Paragraph section of the Properties panel, choose 
an alignment for the text, such as left, centered, right, or 
justify.

Note: For TLF text, Flash provides additional Justify 
alignment options for the last line of text, such as Justify 
With Last Line Aligned To Start or Justify With Last Line 
Aligned To Center.

Figure 13 Properties panel, Character section

Figure 14 Color palette

Hexidecimal color 
value

Color Picker icon
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Adjusting leading and tracking

To improve readability and meet design goals, you can adjust the spacing between lines and characters—leading and 
tracking—for both TLF and Classic text.

Adjusting leading

Leading refers to the space between lines. In Classic text, leading is referred to as line spacing. You are probably used 
to differentiating between single-spaced and double-spaced text. By adjusting leading, you can fine-tune the space 
between lines. By default, leading is set to 120% of the text’s height for TLF text and 0 for Classic text. 

To adjust leading:

1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).

2. Do one of the following:

• For TLF text, drag the Leading scrubber in the 
Character section of the Properties panel 
(Figure 15). You can also click the current Leading 
value and enter a new value. 

• For Classic text, drag the Line Spacing scrubber in 
the Paragraph section of the Properties panel 
(Figure 16). You can also click the current Spacing 
value and enter a new value.

The result of decreased leading is less space between 
lines of text. Increasing leading adds more space between 
lines of text (Figure 17).

Figure 15 Properties panel, Character section

Figure 16 Properties panel, Paragraph section

Figure 17 Increased leading
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Adjusting tracking

Tracking refers to the space between characters across a line of text. In Classic text, tracking is referred to as letter 
spacing. You adjust tracking to space the letters further apart or closer together.

To adjust tracking:

1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).

2. Do one of the following:

• For TLF text, drag the Tracking scrubber in the 
Character section of the Properties panel 
(Figure 18). You can also click the current Tracking 
value and enter a new value.

• For Classic text, drag the Letter Spacing scrubber in 
the Character section of the Properties panel 
(Figure 19). You can also click the current Letter 
Spacing value and enter a new value.

The result of decreased tracking is less space between 
characters. Increasing tracking adds more space between 
characters (Figure 20).

Figure 18 Properties panel, Character section

Figure 19 Properties panel, Character section

Figure 20 Increased tracking
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Applying anti-aliasing

Anti-aliasing lets you smooth the edges of on-screen text. Anti-aliasing is especially useful for small font sizes. When 
anti-aliasing is enabled, all text in the current selection is affected. Anti-aliasing operates with text of all point sizes in 
the same way. You can apply anti-aliasing to TLF text or Classic text.

You can select from the following anti-aliasing options:

Use Device Fonts: The SWF file will use fonts installed on the viewer’s computer to display the fonts. This option 
doesn’t increase the size of the SWF file.You should use this option only with commonly installed fonts, such as 
Verdana or Arial.

Readability: Allows for improved legibility of embedded fonts, particularly at small sizes. To use this option, you 
must embed the font. When you embed fonts, Flash copies the font into the SWF file so that the font does not need to 
be present on the viewer’s computer. This increases the size of the SWF file slightly.

Animation: Creates a smoother animation of text by ignoring alignment and kerning information. To use this option, 
you must embed the font. When you embed fonts, Flash copies the font into the SWF file, so that the font does not 
need to be present on the viewer’s computer. This increases the size of the SWF file slightly. Animation anti-aliasing 
will be hard to read if font size is smaller than 10 points.

For Classic text, you can select two additional anti-aliasing options:

Bitmap Text (No Anti-alias): Useful for displaying small font sizes. Bitmap fonts do not contain outlines, which helps 
keep the file size of a published Flash document to a minimum.

Custom Anti-alias: Modify thickness and sharpness to control the effect anti-alias has on your text.

To set anti-aliasing:

1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).

2. Choose an anti-aliasing option, such as Readability, from 
the Anti-Alias menu in the Character section of the 
Properties panel (Figure 21).

Figure 21 Anti-alias menu for TLF text
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Note: The Font Embedding Warning dialog box opens if 
you select Readability or Animation after selecting Use 
Device Fonts (Figure 22). You can click Embed to open 
the Font Embedding dialog box (Figure 23) and select 
which fonts to embed. You can click Not Now to 
continue without embedding fonts.

You can also open the Font Embedding dialog box by 
clicking Embed in the Character section of the Properties 
panel.

Figure 22 Font Embedding Warning dialog box

Figure 23 Font Embedding dialog box

Applying filters to text

To add interest or fulfill other design goals, you can apply graphics filters to both TLF and Classic text in Flash. 
These filters can make text appear to be raised, give text a shadow, or give text a glow. Graphics filters are available 
in the Filters section of the Properties panel.

Applying the Drop Shadow filter to text

The Drop Shadow filter makes it appear that text or an object is casting a shadow.

To add the Drop Shadow filter to text:

1. Use the Selection tool to select a text container (TLF) or 
field (Classic) with text.

Note: You cannot select the text itself to apply the filter.

2. In the Properties panel, display the Filters section 
(Figure 24).

Note: You may need to scroll down in the Properties 
panel to see the Filters section because it's at the bottom 
of the panel.

3. Click the Add Filter button in the lower-left corner of the 
panel.

Figure 24 Properties panel, Filter section

Add Filter button
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4. Select Drop Shadow in the Filters menu (Figure 25).

The text includes a drop shadow (Figure 26).

You can adjust the characteristics of the Drop Shadow, 
such as its color, in the Filters section of the Properties 
panel (Figure 27).

Figure 25 Filters menu

Figure 26 Drop shadow

Figure 27 Drop shadow properties

Other filters

You can apply several other filters to text to create interesting visual effects.

Blur

The Blur filter softens the edges and details of objects. Applying a blur to an object can make it appear to be behind 
other objects, or make an object appear to be in motion. Adjust the amount and direction of blur by using the X and Y 
text boxes.
How to work with text © 2012 Adobe Systems Incorporated
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Glow

The Glow filter lets you apply a color around the edges of an object.

• Glow: Make the object appear to shine.

• Inner Glow: Apply the glow only within the boundaries of the object.

• Knockout: Remove the object and leave the glow. The object appears outlined in glow.

Bevel

Applying a bevel applies a highlight to the object that makes it appear to be raised above the background surface.

• Inner Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the inside of the 
object.

• Outer Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the outside of the 
object.

• Full Bevel: Apply both inner bevel and outer bevel effects to the object.

You can alter the bevel’s shadow and highlight colors, the type of bevel (inner, outer, or full), its strength, and the 
angle of light that falls on it.

Gradient Glow

Applying a gradient glow produces a glow look with a gradient color across the surface of the glow. The gradient 
glow requires one color at the beginning of the gradient with an Alpha value of 0. You cannot move the position of 
this color, but you can change the color.

Gradient Bevel

Applying a gradient bevel produces a raised look that makes an object appear to be raised above the background, with 
a gradient color across the surface of the bevel. The gradient bevel requires one color in the middle of the gradient 
with an Alpha value of 0.

Adjust color

You can use the Adjust Color filter to finely control the color attributes of the selected object, including contrast, 
brightness, saturation, and hue.

• Brightness: Make the object brighter or darker.

• Contrast: Increase or decrease the distinction between light and dark.

• Saturation: Increase the intensity of color. For example, raising saturation on blue text makes the text a more 
vibrant blue.

• Hue: Increase or decrease the shade of the color.
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How to test a Flash project
Testing your Adobe Flash Professional content before you publish it is very important. This is especially true when 
publishing a movie for multiple screens. For example, may find your movie appears to play fine in a web browser, 
only to discover that it displays incorrectly on the Apple iPad or your mobile phone.

When testing your Flash content, it’s a good idea to perform technical, spelling, grammar, and usability tests. If 
you’re creating a mobile application, you’ll need to perform additional tests of features that are unique to mobile 
applications, including accelerometer, touch-screen, and geolocation functionality. 

Conducting a technical test

A technical test answers questions such as the following:

• Do all the buttons work properly, according to the flowchart?

• Do the text, graphics, animation, and sound match the storyboard?

• Is there proper layout and coordination of text, graphics, animation, and sound as specified in the 
storyboard?

• Does the content in your mobile application react as expected when the device is rotated, tilted, or laid flat?

• Do touch screen features such as click and drag, press and tap, or two-finger tap work properly?

• Do screen gesture features such as swipe and zoom work properly?

To answer these questions, test the Flash content in each target screen or device. You can test SWF content in the 
Adobe Flash Player or in a web browser. You can test mobile application content by physically connecting your 
computer to a mobile device or by using the Adobe Flash device simulator.

Previewing Flash content in the Adobe Flash Player

To test a SWF file without embedding the content in an HTML file, you can open the movie in the Adobe Flash 
Player.

To preview a SWF in the Adobe Flash Player:

1. Select Control > Test Movie > In Flash Professional.

The SWF file opens in the Flash Player window.

2. Click through the content of your movie to see how it runs. Make sure the buttons function properly and that the 
text, graphics, animations, and sound are properly coordinated.

3. Close the preview window.

Previewing Flash content in a browser

You can also test how your content will play in a web page by using the Publish Preview command. For example, if 
you plan to publish the content as an HTML file for the web, you can preview the content in an HTML file.

To preview Flash content in a browser:

1. Select File > Publish Preview > HTML.

An HTML document containing the SWF file for your content opens in your default web browser.

2. Click through the content of your movie to see how it runs in a web browser. Make sure the buttons function 
properly and that the text, graphics, animations, and sound are properly coordinated.

3. Close the browser window.
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Previewing a Flash mobile application by using the Flash device simulator

The Adobe Flash Professional device simulator enables you simulate running your application on a target mobile 
device. The device simulator is only available when your Flash document publish target is a mobile device, such as 
AIR 3.2 For Android or AIR 3.2 For iOS, as shown in the document Properties panel (Figure 1).

Figure 1 Properties panel

To preview a mobile app in the Flash device simulator:

1. Select File > Test Movie > In AIR Debug Launcher 
(Mobile).

The Simulator appears and your application opens in the Device preview window (Figure 2). You can use the 
sliders or change values in the Accelerometer, Touch And Gesture, and Geolocation sections to simulate 
common mobile application features.

Figure 2 Simulator and Device preview windows

Flash document 
publish target
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2. In the Accelerometer section of the Simulator window, 
change the X, Y, and Z values or drag the sliders to 
simulate rotating and tilting the mobile device 
(Figure 3).

3. Click the Reset button to return to the default values.

4. Expand the Touch And Gesture section in the Simulator 
window and select the Touch Layer option (Figure 4).

You can adjust and test the functionality of touch and 
gesture features, such as tapping and swiping. When you 
position the pointer over the preview window, it has a 
yellow circle attached to simulate a finger-tip (Figure 5). 
You can change the size and pressure by using the values 
at the bottom of the Simulator window.

Figure 3 Simulator, Accelerometer section

Figure 4 Simulator, Touch and Gesture section

Figure 5 Touch And Gesture simulation pointer

Reset 
button
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5. Select the feature you want to adjust or test and use the 
mouse pointer in the preview window to test the selected 
feature.   

Instructions for testing the selected feature appear at the 
bottom of the Simulator window (Figure 6).

6. Expand the Geolocation section in the Simulator window 
(Figure 7).

If your application includes geolocation features, you can 
test those here. For example, you may have an 
application that returns a list of local restaurants based on 
the longitude and latitude (location) of the device. To test 
this feature you would enter test Latitude and Longitude 
values, click Send, and evaluate the results in the Device 
preview window.

7. When you’re finished testing your mobile app, close the 
Simulator and Device preview windows.

Figure 6 Touch And Gesture option instructions

Figure 7 Simulator, Geolocation section
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Proofing the Flash content

There is no better way to proof your Flash content than to read each screen or page carefully several times, checking 
against your storyboard. Read text slowly and aloud to check for spelling and grammar errors. Have someone who is 
less familiar with your project proofread the content too.

You can also use the built-in spell checker. Before Flash will check spelling in a document, you must select your spell 
checking options in the Spelling Setup dialog box (Figure 8). Select Text > Spelling Setup to open the Spelling Setup 
dialog box.

Figure 8 Spelling Setup dialog box

To check spelling:

1. Select Text > Spelling Setup.

The Spelling Setup dialog box appears.

2. Review the options in the dialog box and make any 
changes you like.

3. Click OK to close the Spelling Setup dialog box.

4. Select Text > Check Spelling.

The Check Spelling dialog box opens (Figure 9).

5. Use the Check Spelling dialog box as you would any 
other spell checker. For example, click Change to change 
a misspelled word to the word in the Change To text box. Figure 9 Check Spelling dialog box
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Conducting a usability test

Usability tests are sessions in which you observe visitors as they use your application. Their feedback can help you 
improve the application’s organization, navigation, text, use of color, and other factors. To conduct a usability test, 
you need to do the following:

1. Define the audience for your usability test. This audience should resemble the actual users of your application.

2. Develop your goals for the usability testing project. Start by asking the following questions: What should the 
intended audience be able to get out of the application? What do you want to learn about your application? Are 
there any problem areas you’re especially concerned about, such as an unconventional navigation bar?

3. Create a test script. This is a list of tasks the test’s moderator will ask the tester to accomplish. The script should 
also include feedback and follow-up questions to be posed by the moderator. Phrase the questions asked, tasks 
presented, and opinions sought in a way that allows participants to feel they are contributing to the project rather 
than being tested by the moderator. Ask questions such as Do you like the colors? Can you read the text? Where 
would you click to get information on the company/organization?

4. Recruit your testers. Use the characteristics you initially defined for your audience. In addition to these 
characteristics, choose testers for practicality. For example, they should live close enough to the testing location 
to get there easily. You want to make the process as simple as possible for your testers. For maximum efficiency, 
usability professionals recommend a minimum of eight testers.

5. Provide a comfortable, quiet, private testing environment. Ideally, you should videotape participants. Set up the 
camera so it does not point directly at either the participant or the screen, but instead is angled in a way that 
includes both the screen and some part of the user. In professional software testing, there are usually two 
cameras: one camera records the tester's face and another records the screen. Test moderators then analyze the 
session by viewing both recordings side-by-side so that the tester’s reaction can be compared to what the tester is 
doing.

6. Observe the tester (or analyze the video). Look for latent behavior, behavior of which the participants are 
unaware. Latent behavior is found in body language or facial expressions that participants do not verbalize. An 
example of latent behavior is participants moving the pointer around the screen for a short while, looking for 
something, but not documenting that the item was difficult to find. Another example is participants sighing or 
frowning after clicking a link because they are tired of waiting for an image to load; this behavior indicates that 
an image file is too large, but the participant might not document this occurrence.

7. After completing the tests, compile and review your data. As you do so, keep your participants’ comments 
central. Resist the temptation to impose your own opinion. For example, if several users complain about the 
location of a menu, avoid concluding that “they’ll get used to it once they use it.”

For additional information, go to: http://www.utexas.edu/learn/usability/index.html or en.wikipedia.org/wiki/
Usability_testing
How to test a Flash project © 2013 Adobe Systems Incorporated

This document requires Adobe Flash Professional CC, June 2013. Technical instructions may differ depending on your version.



Adobe Flash Professional Guide
How to get started with ActionScript
ActionScript 3.0 is the scripting language of Adobe Flash Professional. You can use ActionScript to add complex 
interactivity, playback control, and data display to your application. For example, you might want to animate a picture 
of a boy walking. By adding ActionScript, you could have the animated boy follow the pointer around the screen, 
stopping whenever he collides with a piece of animated furniture.

ActionScript is an object-oriented programming language. Object-oriented programming is a way to organize the 
code in a program, using code to define objects and then sending messages back and forth between those objects.

You don’t have to be a programmer to take advantage of ActionScript (see “Using Script Assist mode” later in this 
guide). But the following concepts will help:

• Class: The code that defines an object. This code consists of properties, methods, and events. Think of the 
blueprint of a house: you can’t live in the blueprint, but you need it so you can build the house. You use 
classes to create objects.

• Object: An instance of a class. When you instantiate an object (create an instance of it), you declare what 
class it is created from and set its properties. You can create as many objects as you want from a single 
class—if you have a bicycle class, you can create many bicycle objects, each with its own properties (one 
bicycle might be red while another might be green).

• Property: One of the pieces of data bundled together in an object. A property helps define an object—it 
provides the object’s characteristics. A song object might have properties named melody and title. You set 
the properties of an object when you create the object, but you can change them later as needed. A property 
is a variable that belongs to an object.

• Variable: A name that represents a value in the computer’s memory. As you write code, you write the 
variable’s name as a placeholder for the value. This allows you to write code even if you don’t know all the 
possible values a user might provide. If you create a variable firstName, you can tell your program to 
display the user’s first name without knowing in advance what the user’s first name is.

• Method: An action that can be performed by an object. For example, the class horse might have a method 
called gallop(). When the method gallop() is called, it shows an animation of the horse galloping from one 
point to another.

• Function: A block of code that carries out specific tasks and can be reused in your program. For example, 
you might create a function called checkEmail() to verify that a user has provided text that can actually be 
used as an e-mail address. If you ever want to update the function, you only have to do it once instead of in 
each place where e-mail addresses must be validated. You can also think of a method as a function attached 
to an object.

• Event: Something that happens in a Flash movie that ActionScript is aware of and can respond to. Many 
events are related to user interaction—for example, a user clicking a button or pressing a key on the 
keyboard. The technique for specifying certain actions that should be performed in response to particular 
events is known as event handling.

If you’ve worked with symbols in Flash, you’re already used to working with objects. Imagine you’ve defined a 
movie clip symbol—say a drawing of a rectangle—and you’ve placed a copy of it on the Stage. That movie clip 
symbol is also an object in ActionScript; it’s an instance of the MovieClip class. The main timeline of a Flash movie 
also belongs to the MovieClip class.

You can modify various characteristics of any movie clip. When a movie clip is selected, the Properties panel shows 
some of the characteristics you can change, such as its X coordinate or its width. Or you can make color adjustments 
such as changing the clip’s alpha (transparency). Other Flash tools let you make more changes, such as using the Free 
Transform tool to rotate the rectangle. Any way you can modify a movie clip symbol in the Flash authoring 
environment you can also do in ActionScript. In ActionScript, you use the methods of the MovieClip class to 
manipulate or change the properties of your movie clip.
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For more about object-oriented programming, see Programming ActionScript 3.0, “Object-oriented Programming in 
ActionScript” (in Flash, select Help > Flash Help).

Using Script Assist mode

You can add ActionScript in the authoring environment by using the Actions panel (Figure 1). The Script Assist 
mode in the Actions panel can simplify the coding process.

Figure 1 Actions panel in Script Assist mode

In Script Assist mode, you can add ActionScript to your Flash document without writing the code yourself. You 
select actions from the Actions toolbox and set the options for each action in the parameters area. You must know a 
little about what functions to use to accomplish specific tasks, but you don’t have to learn syntax (the grammar of 
ActionScript). Many designers and non-programmers use this mode.

One of the first things to learn is how to stop your movie at a certain spot. You will also learn how to send the 
playhead to a particular frame in the movie.

Actions toolbox

Script navigator

Parameters area

Script Assist 
button

Script pane
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To use ActionScript to stop a movie:

1. Start Flash and open a movie. Create a layer in your 
movie named actions. In the frame that corresponds to 
the end of your movie, insert a new keyframe.

2. If the keyframe is not selected, select it by clicking it.

3. Select Window > Actions to display the Actions panel.

4. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button in the upper-right corner 
(Figure 2).

Classes are organized into packages. You want to add a 
stop() action to a movie clip (in this case, your timeline is 
the movie clip), so you must locate the MovieClip class. 
The MovieClip class is part of the Flash.Display 
package.

5. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Display package to 
display the classes it contains.

6. Scroll down again to find the MovieClip class and click 
to expand it (Figure 3).

7. Click Methods to view the methods available for the 
MovieClip class.

Figure 2 Actions panel

Figure 3 Movie Clip class

Script Assist button
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8. Scroll down to the Stop method. Do one of the following: 

• Double-click the Stop method.

• Drag the Stop method into the Script pane.

Code for applying the Stop method appears in the Script 
pane (Figure 4). The first line (import 
flash.display.MovieClip();) imports the code necessary 
for the MovieClip class. The second line is the Stop 
action itself. The code not_set_yet indicates you need to 
finish the code. You can use Script Assist to do this.

9. Click in the Object field in the parameters area of the 
Actions panel.

The Insert Target Path button is now active. The target 
path helps you locate the object you are trying to control.

10. Click the Insert Target Path button (Figure 4).

The Insert Target Path dialog box appears (Figure 5).

11. Select the Relative option and click Root.

This sets the target path to this.

12. Click OK to close the Insert Target Path dialog box.

The completed script for the Stop method appears in the 
Script pane (Figure 6). This code will cause your movie 
to stop playing at the end of the movie, Frame 20.

Note: In ActionScript, this is used the same way that you 
would refer to yourself as “me” instead of using your full 
name. Remember that the main timeline is an instance of 
the MovieClip class. In Figure 6, Flash uses this to refer 
to the movie clip that Frame 20 belongs to.

13. Close the Actions panel.

Figure 4 Stop method

Figure 5 Insert Target Path dialog box

Figure 6 Stop method applied to frame 20

Insert Target Path button

Frame number
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Event handling

The technique for specifying certain actions that should be performed in response to particular events is known as 
event handling. Event handling consists of three important elements:

• The event source: Which object will trigger the event? For example, which button will be clicked, or which 
Loader object is loading the image?

• The event: What is going to happen, what interaction do you want to respond to? Identifying the event is 
important, because an object can trigger (and listen for) several events.

• The response: What action(s) do you want performed when the event happens?

When an ActionScript program is running, Adobe Flash Player just sits and waits for certain events to happen, and 
when those events happen, the player runs the specific ActionScript code you’ve specified for those events. For the 
program to know what events are important, you must create an event listener. Flash Player executes an event listener 
in response to specific events.

Adding an event listener is a two-step process:

• First, you create a function or class method for Flash Player to execute in response to the event. This function is 
sometimes called the listener function.

• Second, you use the addEventListener() method to connect the listener function with the target of the event. The 
addEventListener() method tells Flash what object to listen to, what event to listen for, and what function to 
execute in response.

To use ActionScript to go to another frame:

1. Create a button users can click to go to a particular frame 
in your movie. Make sure you place the button on the 
Stage (Figure 7).

2. Select the button and use the Properties panel to give the 
button a unique instance name (Figure 8).

3. In the main timeline of your movie, create a layer named 
actions.

4. Create a keyframe in the actions layer that corresponds to 
the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer.

Note: If your button doesn’t appear in this frame, Flash 
will generate an error message because you are referring 
to an object that isn’t on the Stage yet.

5. Select Window > Actions to display the Actions panel.

6. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.

7. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Events package to 
display the classes it contains.

8. Scroll down to the IEventDispatcher class and click it to 
open it.

9. Click Methods to display methods for the 
IEventDispatcher class.

Figure 7 Button instance

Figure 8 Button instance

Instance name
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10. .Double-click the addEventListener method to add it to 
the Script pane (Figure 9).

11. Click in the Object field in the parameters area of the 
Actions panel.

The Insert Target Path button is now active.

12. Click the Insert Target Path button.

The Insert Target Path dialog box appears (Figure 10).

13. Select the Relative option and select the instance name of 
your button. Click OK to close the dialog box.

The event listener is attached to the instance of your 
button (Figure 11). 

Next, you select an event to listen for.

Figure 9 The addEventListener method in the 
Actions toolbox

Figure 10 Insert Target Path dialog box

Figure 11 Event listener code in the Script pane
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14. In the Actions toolbox on the left side of the panel, select 
the CLICK property from the MouseEvent class 
(Figure 12).

To find the CLICK property, open Flash.Events, open 
MouseEvent, and open Properties.

15. In the Script pane, select the addEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field.

16. In the Actions toolbox, double-click the CLICK property.

Script Assist adds the property to your code as  
MouseEvent.CLICK (Figure 13).

Now your code will listen for a click on the button. To 
tell the event listener how to respond when that click 
occurs, you next create a function.

17. In the parameters area, type a name for your function in 
the Listener field, such as startMovie. You can use any 
name you like, but make sure the name of the function is 
unique and contains no spaces (Figure 14).

The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.

18. In the Actions toolbox, select the function keyword from 
Language Elements.

To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword.

19. Double-click the function keyword in the Actions 
toolbox.

The code for creating a function appears in the Script 
pane (Figure 15).

20. In the parameters area of the Script pane, type the name 
of your function in the Name field.

Note: You must type the function name exactly as you 
typed it for the AddEventListener function in Step 17. 
Function names are case-sensitive.

21. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field.

In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).

Figure 12 CLICK property in the Actions toolbox

Figure 13 CLICK property in the Script pane

Figure 14 Function name in the Listener field

Figure 15 Function code
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22. In the parameters area of the Script pane, select Void 
from the Type pop-up menu.

Some functions return a value when called. The keyword 
void indicates that this function does not return a value.

Now you can tell the function what you want it to do 
when the CLICK event occurs.

23. In the Actions toolbox on the left side of the panel, select 
the GotoAndPlay method for the Flash.Display class 
(Figure 16).

To find the GotoAndPlay method, expand Flash.Display, 
and then expand MovieClip and Methods.

24. Select the function in the Script pane and double-click 
the GotoAndPlay method in the Actions toolbox.

The method is added to the function (Figure 17).

25. Click in the Object field in the parameters area of the 
Actions panel.

The Insert Target Path button is now active.

26. Click the Insert Target Path button to display the Insert 
Target Path dialog box.

27. Select the Relative option and select the movie clip you 
want to play when the button is clicked. If you want the 
movie in the main timeline to play, select Root to set the 
target path to this.

28. Click OK to close the Insert Target Path dialog box.

29. In the Frame field, type the number of the frame you 
want to send the playhead to. For example, if you want 
the movie to start from the beginning, type the number 1 
to play the movie’s first frame.

30. Close the Actions panel.

31. Save the movie.

32. Select Control > Test Movie > In Flash Professional to 
test the movie.

33. Select File > Close to close the preview window.

Figure 16 GotoAndPlay method

Figure 17 GotoAndPlay method in the Script pane

For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help).
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Using code snippets

In the Code Snippets panel you can start using simple ActionScript 3.0 very quickly, without knowledge of 
programming or ActionScript 3.0. You can add ActionScript 3.0 code to your Flash file to enable common 
functionality. Here are some of the code snippets you might use:

• Drag And Drop. Users can drag the symbol around the Stage.

• Move With Keyboard Arrows. Users can move the symbol with the keyboard arrows.

• Click To Go To Frame And Stop. The playhead moves to a specific frame and then stops when users click the 
symbol.

• Click To Play/Stop Sound. A sound plays when users click the symbol.

Adding a code snippet to a movie clip symbol instance

You can add code snippets to movie clip symbol instances. Symbols are stored in the library. Whenever you place a 
symbol on the Stage, you are actually placing an instance of the symbol on the Stage. For ActionScript to act on a 
symbol instance, you must give the instance a name.

To add a code snippet to a movie clip symbol instance:

1. Draw an object on the Stage, such as an oval.

2. Convert the object to a Movie Clip symbol.

3. With the object selected, open the Properties panel. 

4. In the Instance Name text box, enter a name for the 
symbol instance (Figure 18). 

5. Select Windows > Code Snippets.

The Code Snippets panel opens (Figure 19).

6. With the movie clip instance still selected, double-click 
the Animation folder in the Code Snippets panel.

Figure 18 Properties panel.

Figure 19 Code Snippets panel
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7. Select the Move With Keyboard Arrows code snippet.

8. Click the Add To Current Frame button in the Code 
Snippets panel (Figure 20).

The Actions panel opens, showing the ActionScript in the 
code snippet (Figure 21).

The Move With Keyboard Arrows code snippet lets users 
move the movie clip with the keyboard arrows when the 
movie runs. For information on other code snippets, see 
Flash Help.

9. After looking at the ActionScript you added, close the 
ActionScript window.

When you added the code snippet, Flash added a new 
layer in the Timeline panel named Actions (Figure 22).  
The ActionScript for the code snippet appears in a new 
keyframe in the Actions layer.

10. Test the movie. Observe that the object moves with the 
keyboard arrows.

Figure 20 Code Snippets panel

Figure 21 Actions panel

Figure 22 Timeline panel
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Symbols, instances, and the library

Symbols and instances

A symbol is a graphic, button, or movie clip you create once in Adobe Flash Professional and can use any number of 
times throughout your movie. Any symbol you create is automatically placed in a storage area called the library for 
the current document.

An instance is a copy of a symbol located on the Stage or on the Pasteboard (the gray area around the Stage). An 
instance can be different from its symbol in color, size, and function. To create an instance of a symbol, drag the 
symbol from the library onto the Stage or Pasteboard. Once you have created an instance, you can use the Color 
Effect options in the Properties panel to change its brightness, tint, alpha, or RGB color settings.

Editing the symbol automatically updates all of its instances, but applying effects to an instance of a symbol updates 
only that instance.

Using symbols offers a number of advantages. Symbols add interactivity to your documents. They save space and 
reduce the download time of your finished movie because Flash does not have to save duplicate information for each 
instance. For example, if you create an animated wheel symbol, you can use several instances of the symbol to create 
the wheels on a train. The result is a much smaller file than if you had created each wheel separately. Symbols also 
help you maintain consistency throughout your Flash document. For example, if you have buttons throughout your 
document, using symbols ensures that all buttons look alike. You can easily edit all instances of buttons in a 
document at once when you use symbols to create them. You can also share symbols between different documents.

When you create a new drawing in Flash, you’re creating a shape, not a symbol. You can convert any shape to a 
symbol by selecting it and then selecting Modify > Convert To Symbol.

Libraries

The library is a container in each movie where Flash stores and organizes symbols, sounds, bitmap graphics, video, 
and other elements. The library is attached to the document you’re working on. By default, the Libary panel is open in 
the right-side of the workspace next to the Properties panel (Figure 1). If it’s not open, select Window > Library. If 
you share your document with someone else, and they open it on their computer, they will see the same library 
objects. You can also open libraries from other documents by selecting File > Import > Open External Library. As 
your documents become more complex, you’ll find it helpful to use folders to sort your content into related groups 
within the library.

Figure 1 Library panel
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Types of symbols

Flash has three types of symbols: graphic, button, and movie clip.

Each symbol has a unique timeline and Stage, complete with layers. When you create a symbol, you choose the 
symbol type, depending on how you want to use the symbol in your document.

• Use graphic symbols for static images and to create reusable pieces of animation that are tied to the main 
timeline. Graphic symbols operate in sync with the main timeline. Interactive controls and sounds won’t 
work in an animation sequence contained in a graphic symbol.

• Use button symbols to create interactive buttons that respond to mouse clicks, rollovers, and other site visitor 
actions. You define the graphics associated with various button states and then assign actions to a button 
instance.

• Use movie clip symbols to create reusable pieces of animation. A movie clip has its own timeline that is 
independent from the main timeline—think of it as a sub-timeline nested inside the main timeline. Movie 
clips can contain interactive controls, sounds, and even other movie clip instances.

Creating symbols

You create symbols in one of two ways:

• Select Insert > New Symbol. This creates a new symbol to which you must add content.

• Select an existing shape (that you’ve drawn) or image (that you’ve imported) and select Modify > Convert 
To Symbol.
Symbols, instances, and the library © 2012 Adobe Systems Incorporated
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How to publish a Flash document
You develop content in Adobe Flash Professional by using a Flash FLA document. These documents have a .fla 
extension and can be opened and edited in Flash.

For other people to see your movie, you publish it in a format that is accessible by other software. You use the 
Publish Settings dialog box or the Publish section in the document Properties panel to determine which formats to 
publish.

Publishing a Flash document for the web

By default, the Publish command creates a Flash SWF file, an HTML document that inserts your Flash content in a 
browser window, and a JavaScript file labeled AC_OETags.js that lets your SWF file play automatically in active 
content-compliant browsers. 

To publish a Flash document for the web:

1. Start Flash and open the document you want to publish.

2. Make sure nothing on the Stage is selected (Edit > 
Deselect All). 

3. In the Properties panel (Window > Properties), expand 
the Publish section (Figure 1).

In the Properties panel, you can select the Target runtime 
for the document and select the ActionScript version that 
matches your document.

4. Click to open the Target menu (Figure 2).

You can publish the document for the Flash Player 
runtime, as an Adobe AIR application, or for playback on 
a device running Flash Lite. For web publishing, you 
select a target version of the Flash Player.

You can publish a document for the most current version 
of the Flash Player or for older versions of the Flash 
Player. 

Note: Some features available in an ActionScript 3 
document may not run properly in older versions of the 
Flash Player. It’s usually best to publish for the most 
current version of the Flash Player.

5. Select a target Flash Player version.

Figure 1 Properties panel, Publish section

Figure 2 Target menu
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6. Click Publish Settings in the Properties panel.

The Publish Settings dialog box appears (Figure 3). It 
shows the most recently selected options. Notice you can 
also select the target runtime and ActionScript version in 
the Publish Settings dialog box.

The default, Flash publishes a Flash (.swf) file, and an 
HTML Wrapper. These are the correct selections if you 
are publishing your content to run in a web browser. 

7. In the list of publish format options, make sure the Flash 
(.swf) and HTML Wrapper options are both selected.

8. Click on the Flash (.swf) option to display the Flash 
publish settings on the right (Figure 4). Be careful not to 
deselect the option.

The default location for published files is to place them in 
the same location as the FLA file. To select a new 
location for the published files, you can click the folder 
icon beside the Output File text box, navigate to the new 
location, and click Save.

You can adjust the JPEG image quality. A higher value 
produces better looking images and larger files.

To make highly compressed JPEG images look 
smoother, select the option Enable JPEG Deblocking. 
This reduces artifacts resulting from JPEG compression. 

To set the audio sample rate and compression for all 
streaming sounds or event sounds in the SWF file, click 
the current Audio Stream or Audio Event setting and 
select new options as needed. 

Note: A streaming sound plays as soon as enough data 
for the first few frames downloads; it is synchronized to 
the timeline. An event sound does not play until it 
downloads completely, and it continues to play until 
stopped.

To override settings for individual sounds specified in the 
Sound section of the Properties panel, select the option 
Override Sound Settings. 

Note: If the Select Override Sound Settings option is 
deselected, Flash scans all stream sounds in the document 
(including sounds in imported video) and publishes all 
stream sounds at the highest individual setting. This can 
increase file size if one or more stream sounds has a high 
export setting. 

To export sounds suitable for devices, including mobile 
devices, instead of the original library sound, select the 
option Export Device Sounds. 

Figure 3 Publish Settings dialog box

Figure 4 Flash (.swf) publish settings
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9. Click the HTML Wrapper option on the left to display 
the HTML publish settings on the right (Figure 5). Be 
careful not to deselect the option.

You can select the template to use for creating the Flash 
HTML page the contains your SWF file. A Flash HTML 
template is a file that contains HTML code and flexible 
template code consisting of a special type of variables 
(which differ from ActionScript variables). When you 
publish a SWF file, Flash replaces these variables with 
the HTML publish options you select in the Publish 
Settings dialog box and produces an HTML page with 
your SWF file embedded.

If you are publishing to Flash Player version 4 or later, 
select Detect Flash Version. Flash version detection 
configures your document to detect the version of Flash 
Player that the user has and sends the user to an 
alternative HTML page if the user does not have the 
targeted player.

By default, the file dimensions are set to match that of the 
movie you’re publishing. You can specify new 
dimensions in pixels or as a percent of the current movie 
size.

There are four Playback control options (Figure 6). 
These include:

• Paused At Start pauses the SWF file until a user 
clicks a button or selects Play from the shortcut 
menu. (Default) The option is deselected and the 
content begins to play as soon as it is loaded.

• Loop repeats the content when it reaches the last 
frame. Deselect this option to stop the content when 
it reaches the last frame. This is on by default. 

• Display Menu shows a shortcut menu when users 
right-click (Windows) or Control-click (Mac OS) the 
SWF file. To show only About Flash in the shortcut 
menu, deselect this option. This option is selected by 
default.

• Device Font substitutes anti-aliased (smooth-edged) 
system fonts for fonts not installed on the user’s 
system. 

To determine the trade-off between processing time and 
appearance, you can open the Quality menu and select 
from six quality options that range from Low to Best 
(Figure 6). 

Figure 5 HTML publish settings

Figure 6 HTML playback and Quality options
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To modify the style of the window that contains your 
HTML file, you can open the Window Mode menu 
(Figure 7) and select from four window options:

• Window uses the HTML background color behind 
the content.

• Opaque Windowless sets the background of the 
Flash content to opaque, obscuring anything under 
the content. Lets HTML content appear above or on 
top of content.

• Transparent Windowless sets the background of the 
Flash content to transparent, allowing the HTML 
content to appear above and below the content. This 
requires viewing in a browser that supports 
windowless content.

• Direct turns on hardware acceleration. By default 
this is turned off. 

You can use the settings in the Scale and Alignment 
section of the HTML publish settings (Figure 8) to 
control how the SWF content is aligned in the HTML 
page. You can also specify if and how a browser scales 
the SWF content when a user changes the size of their 
browser window. 

10. Click Publish at the bottom of the Publish Settings dialog 
box.

Flash publishes files in the same folder as your FLA or to 
another output location that you specified. 

11. Click OK to save these settings for the current file and to 
close the Publish Settings dialog box.

Note: After setting publish options, you can choose 
File > Publish to publish without opening the Publish 
Settings dialog box.

12. To view the published document, open the folder that 
contains the published file and double-click the HTML 
file. 

The HTML file opens in your default web browser and 
displays the SWF content.

Figure 7 HTML Window Mode menu

Figure 8 HTML scale and alignment settings
How to publish a Flash document © 2012 Adobe Systems Incorporated
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Publishing a Windows or Mac OS projector file

To create a self-contained application file that runs without the Flash Player installed, publish your Flash document as 
a Windows or Mac OS projector file.

To publish a projector file:

1. Start Flash and open the document you want to publish.

2. Make sure nothing on the Stage is selected (Edit > 
Deselect All). 

3. In the Properties panel (Window > Properties), expand 
the Publish section.

4. Click Publish Settings to open the Publish Settings dialog 
box.

5. Select Win Projector or Mac Projector from the list of 
publish format options (Figure 9).

6. Click Publish to publish the projector file, or click OK to 
save your publish settings and publish at a later time.

Figure 9 Publish format options

Publishing an Adobe AIR application

You can also publish Adobe Flash Professional documents as Adobe AIR applications. The Adobe AIR runtime 
makes it possible to deploy your Flash movie as a stand-alone desktop application that runs without opening a web 
browser. You can also publish Adobe AIR applications that run on popular mobile devices, including Android phones 
and tablets as well as iOS devices (iPhones and iPads). You can even create an Adobe AIR app that runs on your 
television.

To publish an Adobe AIR application:

1. Start Flash and open the document you want to publish.

2. Make sure nothing on the Stage is selected (Edit > 
Deselect All).  

3. In the Properties panel (Window > Properties), expand 
the Publish section.

4. Click Publish Settings to open the Publish Settings dialog 
box.

5. Select Flash (.swf) from the list of publish format options 
(Figure 10).

Figure 10 Publish format options
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6. In the Publish Settings dialog box, open the Target menu 
(Figure 11). 

7. Select a target runtime option that matches your target 
device, such as AIR 3.2 for Anroid.or AIR 3.2 for 
Desktop.

8. Click Publish.

The AIR Settings dialog box opens to the Signature tab 
(Figure 12). The first thing you need to do is select or 
create a certificate for the AIR application.

9. Click Create (Windows) or New (Mac OS) to create a 
new certificate.

The Create Self-Signed Digital Certificate dialog box 
(unamed in Mac OS) appears (Figure 13). All fields must 
be filled in to create the new certificate

10. Complete the form, including the password fields. 

11. Click in the Save As text box and enter a name for the 
certificate.

12. Click Browse (Windows) or the folder icon (Mac OS), 
select a target location for the new certificate, and click 
Save.

13. Click OK to create the certificate.

A confirmation message appears when the certificate is 
created.

14. Click OK to close the message.

15. Click in the Password text box and enter the password 
you created for the new certificate.

Figure 11 Publish Settings Target menu

Figure 12 AIR Settings dialog box

Figure 13 Create Self-Signed Digital Certificate 
dialog box
How to publish a Flash document © 2012 Adobe Systems Incorporated
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16. Click the General tab in the AIR Settings dialog box.

You can enter a file name for the AIR installer file (.air) 
and enter a name and version number for the application 
(Figure 14).

You can include other information, including a 
description and copyright messaging. 

17. Click Publish to create the AIR application or click OK 
to save your publish settings and publish at a later time.

Flash publishes the AIR application and a message 
appears when the process is complete.

18. Click OK to close the message, and then click OK twice 
to close the AIR Settings and Publish Settings dialog 
boxes.

19. Open the folder you designated as the location for the 
published AIR application. 

The folder contains the AIR installer file (Figure 15). 
You share this file with users who can double-click the 
AIR file to install and run the application. 

Figure 14 AIR Settings dialog box, General tab

Figure 15 Published AIR application files
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Exporting Flash content as an image

Sometimes you may want to export Flash content as an image for use in another document. You can export Flash 
content in JPEG, PNG, or GIF format. 

To export Flash content as an image:

1. Start Flash and open the document you want to publish.

2. Make sure nothing is selected on the Stage. 

3. Open the Properties panel (if it is not already open) and 
expand the Publish section.

4. Click Publish Settings to open the Publish Settings dialog 
box(Figure 16).

5. Select a graphic file type for the image in the list of 
publish format options in the Publish Settings dialog box.

6. If you want to change the names of the image, enter new 
name in the Output file field.

By default, every file type uses the same name as the 
FLA file. Only the file extensions are different.

7. Click Publish to create the image.

By default, files are published in the same folder as the 
FLA file.

Figure 16 Publish Settings dialog box
How to publish a Flash document © 2012 Adobe Systems Incorporated
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Flash Professional CC—Study Guide Sample Questions 

RESPONSE EXAMPLES 
 
1. Which two factors should be most considered when determining the target audience for a Flash 
ad promoting Role Playing Games? (Choose two.) 
 

A. Education 
B. Age 
C. Residence 
D. Gender 
E. Occupation 

 
Correct Answer: B, D 
 
2. Which Mobile App Template could be used for display on an iPhone? 
 

A. AIR for Android: 460 x 300 Blank 
B. AIR for Android: 800 x 480 Blank 
C. AIR for iOS: 480 x 320 Blank 
D. AIR for iOS: 960 x 640 Blank 

 
Correct Answer: C 
 
3. Which information is used in replacement of publication information when citing a Web page? 
 

A. The name of the publisher 
B. The URL (Uniform Resource Locator) 
C. The edition of the publication 
D. The DNS (Domain Name Service) 

 
Correct Answer: B 
 
4.  Which option contains the correct order of events in project management? 
 

A. Planning, Building, Designing, Testing, Launching 
B. Building, Planning, Testing, Designing, Launching 
C. Planning, Designing, Building, Testing, Launching 
D. Planning, Designing, Building, Launching, Testing 

 
Correct Answer: C 
  
5.  Which option is a fundamental characteristic of a motion preset? 



A. Unable to create personal custom motion presets 
B. Can only be applied to symbols 
C. Can reassign them to text fields and symbols 
D. When deleting a symbol, associated tween span with it’s property keyframes is also deleted 

 
Correct Answer: C 
 
6.  What is the main purpose of creating a storyboard? 
 

A. Show the order of each screen 
B. Laying out the navigation 
C. Linking all the various pieces together to make it interactive 
D. Show where the various elements on each screen of your project are going to be presented 

 
Correct Answer: D 
 
7.  Which practice would allow ActionScript to target objects or frames within a Flash movie?  
 

A. Organize layers into folders 
B. Place labels on keyframes within the timeline 
C. Name symbols according to their symbol type 
D. Give instance names to graphic symbols 

 
Correct Answer: B 
 
8.  Which option is true about the frame rate’s affect on an animation performance? 
 

A. A 100 frame movie with a frame rate of 24 fps will last for more seconds than a frame rate of 
12 fps 

B. The complexity of an animation and the speed of the computer on which the animation is 
being played have no affect on the smoothness of the playback 

C. A 100 frame movie with a frame rate of 12 fps will last fewer seconds than a frame rate of 24 
fps  

D. The complexity of an animation and the speed of the computer on which the animation is 
being played affect the smoothness of the playback 

 
Correct Answer: D 
 
9.  Which option describes the advantage of using the Motion Editor to control your Motion 
Tweens? 
 

A. Only method to add different Easing presets, add multiple presets, or create a Custom ease 
B. Only method to edit a Motion Tween 
C. Only method to see more frames than the main timeline 
D. Only method to use keyboard shortcuts for adding or removing keyframes 

 
Correct Answer: A 
 
10.  Which technique will best optimize the file size of a Flash document? 



 
A. Use symbols for every single element that appears 
B. Use AAC, the smallest sound format whenever possible 
C. When creating animation sequences, use tweened animations 
D. Convert your Flash project to a desktop application 

 
Correct Answer: C 

SIMULATION EXAMPLES 

1. Using the Properties panel, add an Alpha Color Effect to the Welcome Symbol. Change the 
symbol’s Alpha value to 0% at Frame 1, and 80% at Frame 35. 

 

Method of Completion: 

1. Click on the Welcome Symbol 
2. Under Color Effect in the Properties Inspector, click the Style dropdown 
3. Click Alpha 
4. Be sure Frame 1 is selected 
5. Change the Alpha to 0% 
6. Select Frame 35 
7. Click on the Welcome symbol to select it 
8. Change the Alpha to 80% 

 
2.  Add a second layer, and rename the top layer Audio and the bottom layer Graphics. (Note: 
Accept  all other default settings.) 
 
 



 
 
Method of Completion: 

1. Click the New Layer icon at the bottom left-hand corner of the Timeline panel. 
2. Double-click the text on layer one and rename it Graphics 
3. Double-click the text on layer two and rename it Audio 

OR 
1. Select Insert > Timeline 
2. Click the Layer menu item 
3. Right-click on Layer 1 in the Timeline OR Go to Modify > Timeline in the main menu 
4. Choose Properties OR Select Layer Properties 
5. Rename the layer “Graphics” 
6. Click OK OR Press the ENTER key 
7. Right-click on Layer 2 in the Timeline OR Go to Modify > Timeline in the main menu 
8. Choose Properties OR Select Layer Properties 
9. Rename Layer 2 “Audio” 
10. Click OK OR Press the ENTER key 

OR 
1. Right Click on the Layer 1 of the Timeline panel 
2. Select the Insert Layer option in the Right Click menu 
3. Double-click the text on layer one and rename it “Graphics” 
4. Double-click the text on layer two and rename it “Audio” 

 
 
3. Add the text Workshops as an expanding-width text block directly below the title Technology 
Conference and near the left edge of the stage. 



 
 
Method of Completion: 

1. Click the Text Tool  
2. Click in the stage area below the title and near the left edge to create a text field 
3. Type “Workshops” 
4. Click away or select selection tool to finalize entry 

 
4.  Convert the shark graphic into a Movie Clip Symbol named mcShark. 
 

 
 
Method of Completion: 

1. Select the shark graphic on the stage  
2. Select Modify > Convert to Symbol 
3. Type mcShark 
4. Select Movie Clip as the symbol type (if it is needed) 
5. Click OK 

OR 



1. Select the shark graphic 
2. Use the keyboard shortcut F8 to Convert to Symbol 
3. Type mcShark 
4. Select Movie Clip as the Type (if it is needed) 
5. Click OK 

OR 
1. Right-click on the shark graphic and choose Convert to Symbol 
2. Type mcShark 
3. Select Movie Clip as the symbol type (if it is needed) 
4. Click OK 

 
 
5. Add two instances of the twinkleStarGR symbol to the sky area of the stage. Select one instance 
and change the First Looping option to 20 to add a twinkling effect. 
 

 
 
Method of Completion: 

1. Select the Library panel  
2. Click and drag two instances of the twinkleStarGR symbol onto the stage above the tree 
3. Select one of the instances and choose the Properties panel 
4. Highlight the number 1 next to First: 
5. Type in 20 
6. Hit Enter OR Set the rollover to 20 

OR 
1. Select the Library panel 



2. Click and drag one instance of the twinkleStarGR symbol onto the stage above the tree 
3. Select one of the instances and choose Edit > Copy OR Select on of the instances and Righ 

Click on Stage and select Copy 
4. Select Edit > Paste in Center OR Right Click and Select Paste in Center 
5. Select the Properties panel 
6. Highlight the number 1 next to First: 
7. Type in 20 
8. Hit Enter OR Set the rollover to 20 

OR 
1. Select the Library panel 
2. Click and drag one instance of the twinkleStarGR symbol onto the stage above the tree 
3. Select one of the instances and choose Control + C 
4. Select Control + V 
5. Select the the Properties panel 
6. Highlight the number 1 next to First: 
7. Type in 20 
8. Hit Enter OR Set the rollover to 20 

 
 
6.  Create a new layer named Mask Animation. Add the grCircle symbol to the new layer on Frame 
1 at an X and Y position of 393.00 and 248.00. Create a Motion Tween to grCircle, and on Frame 45 
position it to an X and Y position of 0.00 and 0.00.  Mask the new layer. 
 

 
 
Method of Completion: 



1. Click on the New Layer icon at the bottom of the timeline  
2. Double-click on the text Layer One and type Mask Animation 
3. Click and drag grCircle from the Library to the stage 
4. Use the Properties Inspector to position grCircle to an X and Y of 393 and 248 
5. Right-click on the Mask Animation timeline OR Right-click on the grCircle symbol 
6. Choose Create Motion Tween 
7. Click Frame 45 to move the playhead 
8. Use the Properties Panel to position the circle at an X and Y of 0.00 and 0.00 
9. Right-click the Mask Animation layer and choose Mask 
10. Hit the Enter or Return key (This step is not required to finish the Task successfully). 

OR 
1. Select Insert > Timeline > Layer 
2. Right-click on the text Layer One and choose Layer Properties 
3. Type Mask Animation 
4. Click and drag grCircle from the Library and use the Properties Inspector to position grCircle to 

an X and Y of 393 and 248 
5. Click on the Mask Animation layer 
6. Select Insert > Motion Tween 
7. Click Frame 45 to move the playhead 
8. Use the Properties Inspector to position grCircle to an X and Y of 0.00 and 0.00 
9. Select Modify > Timeline > Layer Properties 
10. Select the radio button next to Mask and click OK. 
11. Hit the Enter or Return key. (This step is not required to finish the Task successfully). 

 
 
7.  Import sound.wav to the library. Using the Properties panel, add the sound to the voice layer 
and set the Sync to Stream. 
 



 
 
Method of Completion: 

1. Select File> Import 
2. Click Import to Library OR Click Import to stage 
3. Click sound.wav and choose open OR Double click sound.wav OR Click sound.wav and press 

the ENTER key 
4. Select frame 1 of the voice layer OR Select the voice layer 
5. Click on the dropdown next to None in the Sound menu section of the Properties panel 
6. Select sound.wav 
7. Click on the dropdown menu to the right of Sync 
8. Choose Stream 

OR 
1. Use the Keyboard shortcut Control + R 
2. Click sound.wav and choose open OR Double click sound.wav OR Click sound.wav and press 

the ENTER key 
3. Select frame 1 of the voice layer OR Select the voice layer 
4. Click on the dropdown next to None in the Sound menu section of the Properties panel 
5. Select sound.wav 
6. Click on the dropdown menu to the right of Sync 
7. Choose Stream 

 
 
8.  Set the Publish Settings so the target is Flash Player 10.3. For the HTML document, detect the 
flash version, disable playback looping, and change the window mode to Transparent Windowless. 
Publish the files and OK the changes. (Note: Accept all other default settings.) 



 
 
Method of Completion: 

1. Select File> Publish Settings OR Select the Publish Settings button from the Properties Panel 
OR Select Control + Shift + F12 

2. Select Target and change to Flash Player 10.3 
3. From the Other Formats options Select the words HTML Wrapper 
4. Click on the checkbox Detect Flash version 
5. Deselect the checkbox Loop 
6. Click on the dropdown arrow next to Window Mode and choose Transparent Windowless 
7. Click on Publish and OK 

OR 
1. Select Target > Flash Player 10.3 
2. Select the Publish Settings button from the Properties Panel 
3. From the Other Formats options Select the words HTML Wrapper 
4. Click on the checkbox Detect Flash version 
5. Deselect the checkbox Loop 
6. Click on the dropdown arrow next to Window Mode and choose Transparent Windowless 
7. Click on Publish and OK 

 
 
9.  Make the mcAdvertisment Movie Clip accessible and give it the name Advertisement for Travel 
Website. 
 

 



 
Method of Completion: 

1. With the Movie Clip object selected, choose the drop-down to the left of Accessibility in the 
Properties panel 

2. Select the checkbox Make object accessible 
3. Select the Name text field 
4. Type Advertisement for Travel Website 
5. Press Enter or click elsewhere 

 
10.  Test the Movie and use the Output and Timeline Panels to identify the ActionScript error for 
the Lightning button. Fix the file so that it plays without error. 
 
Method of Completion: 

1. Use the keyboard shortcut Control + enter to test the movie OR Select Control >Test OR 
Select Control > Test Movie > In Flash Professional 

2. Click the Lightning button 
3. Click on the X in the top right corner of the swf window to close the swf OR Use the keyboard 

shortcut Control + W to close the swf 
4. Select the Timeline tab 
5. Right-click on frame 1 of the Actions layer 
6. Click Actions OR Click Window in the Menu then Click Actions 
7. Select the l in lightning and change it to an upper case L 

OR 
1. Use the keyboard shortcut Control + enter to test the movie OR Select Control >Test OR 

Select Control > Test Movie > In Flash Professional 
2. Click the Lightning button 
3. Click on the X in the top right corner of the swf window to close the swf OR Use the keboard 

shortcut Control + W to close the swf 
4. Select the Timeline tab 
5. Select frame 10 of the labels layer of the Actions layer 
6. In the Properties Panel in the Label field, select the L in Lightning and change it to a lowercase 

l 
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